maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carlos Sanchez (JIRA)" <>
Subject [jira] Updated: (MECLIPSE-267) Resolve version ranges in make-artifacts
Date Thu, 07 Jun 2007 23:08:59 GMT


Carlos Sanchez updated MECLIPSE-267:

    Summary: Resolve version ranges in make-artifacts  (was: Enhance make-artifacts to not
create POMs that have version ranges)

> Resolve version ranges in make-artifacts
> ----------------------------------------
>                 Key: MECLIPSE-267
>                 URL:
>             Project: Maven 2.x Eclipse Plugin
>          Issue Type: Improvement
>          Components: PDE support
>    Affects Versions: 2.3
>            Reporter: Micah Whitacre
>            Assignee: Carlos Sanchez
>             Fix For: 2.4
>         Attachments: MECLIPSE-267-maven-eclipse-plugin.patch
> Currently when using the make-artifacts goal to deploy Eclipse artifacts to a remote
repository the POMs are created in such a way the versions of the dependencies have ranges
similar to [3.3,4).  This information is pulled from the Manifest.  I'd like a way to specify
not to use those version ranges in the POM but to instead have a soft dependency on a specific
version.  The situation that is occurring is that when I have deployed both Eclipse 3.2 and
3.3 endstates to a remote repository, the 3.2 dependencies have ranges specified which then
pull in the 3.3 endstates.  This causes conflicts when I want to only include 3.2 endstates.
 If there was a way to 1. not use version ranges in the POM and 2. instead have a soft dependency
on a specific version.  This would eliminate the need to specify each and every Eclipse 3.2
artifact for fear a transitive 3.3 dependency got pulled in.
> I have also seen this cause errors when a transitive dependency pulls in a 3.3 endstate
that has conflicting version ranges for an artifact I have a dependency on.  Since the 3.3
endstates will have version ranges of [3.3,4) but I might specify 3.2 dependencies, if I have
a first class dependency on 3.2 and a transitive dependency on the same artifact but the range
is [3.3,4),  I will not be able to build my project.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:


View raw message