maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wendy Smoak (JIRA)" <j...@codehaus.org>
Subject [jira] Updated: (MNG-2590) NPE when listed POM repository is missing the <id> element
Date Thu, 14 Jun 2007 20:33:58 GMT

     [ http://jira.codehaus.org/browse/MNG-2590?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Wendy Smoak updated MNG-2590:
-----------------------------

    Summary: NPE when listed POM repository is missing the <id> element  (was: NPE when
listed POM repository == local repository)

> NPE when listed POM repository is missing the <id> element
> ----------------------------------------------------------
>
>                 Key: MNG-2590
>                 URL: http://jira.codehaus.org/browse/MNG-2590
>             Project: Maven 2
>          Issue Type: Bug
>          Components: Bootstrap & Build
>    Affects Versions: 2.0.4
>         Environment: OS-X 10.4.8 JDK 1.5.0_06
>            Reporter: Brian Topping
>            Priority: Minor
>
> I created a remote repository as such:
> <repositories>
>     <repository>
>         <name>Brian's Repo</name>
>         <url>http://brian/repository/</url>
>     </repository>
> </repositories>
> This results in an NPE:
> java.lang.NullPointerException
> 	at org.apache.maven.wagon.repository.Repository.hashCode(Repository.java:239)
> 	at java.util.HashMap.hash(HashMap.java:264)
> 	at java.util.HashMap.containsKey(HashMap.java:342)
> 	at java.util.HashSet.contains(HashSet.java:182)
> 	at org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(DefaultMavenProjectBuilder.java:964)
> 	at org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(DefaultMavenProjectBuilder.java:1176)
> 	at org.apache.maven.project.DefaultMavenProjectBuilder.buildInternal(DefaultMavenProjectBuilder.java:674)
> 	at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromSourceFileInternal(DefaultMavenProjectBuilder.java:416)
> 	at org.apache.maven.project.DefaultMavenProjectBuilder.build(DefaultMavenProjectBuilder.java:192)
> 	at org.apache.maven.DefaultMaven.getProject(DefaultMaven.java:515)
> 	at org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:447)
> 	at org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:351)
> 	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:278)
> 	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:115)
> 	at org.apache.maven.cli.MavenCli.main(MavenCli.java:256)
> This is because the <id> element is missing.  The schema should be updated such
that the <id> element is mandatory.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message