maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Fox (JIRA)" <j...@codehaus.org>
Subject [jira] Reopened: (MDEP-50) dependency:unpack doesn't seem to handle version ranges
Date Mon, 12 Feb 2007 19:01:21 GMT

     [ http://jira.codehaus.org/browse/MDEP-50?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Brian Fox reopened MDEP-50:
---------------------------


The code changes for this are destabilizing core functionality.

> dependency:unpack doesn't seem to handle version ranges
> -------------------------------------------------------
>
>                 Key: MDEP-50
>                 URL: http://jira.codehaus.org/browse/MDEP-50
>             Project: Maven 2.x Dependency Plugin
>          Issue Type: Bug
>    Affects Versions: 1.0
>         Environment: Java 1.5
>            Reporter: Martin Goldhahn
>         Assigned To: Brian Fox
>             Fix For: 2.0-alpha-2
>
>
> When I use the dependency unpack goal and a version range as shown below, Maven cannot
download the artifact from the repository. There is a version 1.4.1 in the repository. If
I use the specific version number 1.4.1. It works.
>     <build>
>       <plugin>
>         <groupId>org.codehaus.mojo</groupId>
>         <artifactId>dependency-maven-plugin</artifactId>
>         <executions>
>           <execution>
>             <id>unpack</id>
>             <phase>compile</phase>
>             <goals>
>               <goal>unpack</goal>
>             </goals>
>             <configuration>
>               <artifactItems>
>                 <artifactItem>
>                   <groupId>my.package</groupId>
>                   <artifactId>concept</artifactId>
>                   <version>[1.4,1.5)</version>
>                   <classifier>res</classifier>
>                   <outputDirectory>${project.build.sourceDirectory}/../webapp/res</outputDirectory>
>                 </artifactItem>
>               </artifactItems>
>             </configuration>
>           </execution>
>         </executions>
>       </plugin>

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message