maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carlos Sanchez (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MCOMPILER-46) JDK defaulting to 1.4
Date Fri, 12 Jan 2007 23:31:21 GMT
    [ http://jira.codehaus.org/browse/MCOMPILER-46?page=comments#action_84886 ] 
            
Carlos Sanchez commented on MCOMPILER-46:
-----------------------------------------

are you sure? if defaults to the specified in JAVA_HOME

> JDK defaulting to 1.4
> ---------------------
>
>                 Key: MCOMPILER-46
>                 URL: http://jira.codehaus.org/browse/MCOMPILER-46
>             Project: Maven 2.x Compiler Plugin
>          Issue Type: Improvement
>            Reporter: Emmanuel L├ęcharny
>            Priority: Minor
>
> When you declare a <build> tags in which the <plugin> tag is empty (<plugins/>),
the jdk version default to 1.4. 
> Wouldn't it be good - or at least better - to default to the JDK which has been used
to launch maven ? If a project really need a specific version of JDK, then I bet the developper
has correctly set the <configuration> parameters into the pom.xml, I think.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message