maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kenney Westerhof (JIRA)" <j...@codehaus.org>
Subject [jira] Updated: (MNG-2413) maven version insistence based on wrong variable
Date Thu, 02 Nov 2006 16:03:28 GMT
     [ http://jira.codehaus.org/browse/MNG-2413?page=all ]

Kenney Westerhof updated MNG-2413:
----------------------------------

    Fix Version/s:     (was: 2.0.5)
                   2.0.6

> maven version insistence based on wrong variable
> ------------------------------------------------
>
>                 Key: MNG-2413
>                 URL: http://jira.codehaus.org/browse/MNG-2413
>             Project: Maven 2
>          Issue Type: Bug
>          Components: Bootstrap & Build
>    Affects Versions: 2.0.4
>         Environment: OS : ubuntu dapper
> java vm : SableVM 1.11.3
>            Reporter: j
>             Fix For: 2.0.6
>
>
> MavenCli does
> if (System.getProperty("java.class.version", "44.0").compareTo("48.0") < 0) //then
echo "sorry we need version 1.4"
> however java.class.version is the binary packaging format for the classes, not the supported
API.  java.version is the supported api, for which sable returns 1.4.2.  So the process aborts
out, wanting the 1.4 API, when it has 1.4 API (sable has 46.0 instead of 48.0 as the class
packaging format used)

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message