maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Yandell (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MEV-459) Velocity should not depend on Velocity-dep
Date Thu, 16 Nov 2006 21:41:31 GMT
    [ http://jira.codehaus.org/browse/MEV-459?page=comments#action_80346 ] 
            
Henri Yandell commented on MEV-459:
-----------------------------------

This seems like a problem then. People will be unable to use Velocity 1.4 as it has a screwed
up pom, and the Velocity guys aren't going to be creating a release just to fix a Maven screw-up.

Velocity 1.5 is on its way, so if someone uses the pom that is in Velocity's trunk when they
add it to the maven repo then that one will be fine (odd that the 1.4 pom is bad, as there
has been a pom in velocity since 2002 and I can't see it ever having this -deps dependency).

Additionallyl, should the velocity-deps jar be in the maven repo at all? It seems like it
should be removed as it's not intended for maven style use.

> Velocity should not depend on Velocity-dep
> ------------------------------------------
>
>                 Key: MEV-459
>                 URL: http://jira.codehaus.org/browse/MEV-459
>             Project: Maven Evangelism
>          Issue Type: Bug
>          Components: Dependencies
>            Reporter: Vincent Massol
>
> If a project is using ORO in version 2.0.8 then velocity-dep clashes with it as it includes
ORO with the original package name (a really really bad practice). 
> For information, the problem arises for example with Perl5Substitution.appendSubstitution(java.lang.StringBuffer
stringBuffer, org.apache.oro.text.regex.MatchResult matchResult, int i, java.lang.String string,
org.apache.oro.text.regex.PatternMatcher patternMatcher, org.apache.oro.text.regex.Pattern
pattern) which is valid in ORO 2.0.8 but not in the version inside velocity-dep.
> This problem should be raised against the Velocity project as it should not be allowed
to internally include another external package.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message