maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Remy Coqueugniot (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MIDEA-74) Plugin doesn't handle correctly WebModule dependency scope
Date Thu, 12 Oct 2006 16:28:52 GMT
Plugin doesn't handle correctly WebModule dependency scope
----------------------------------------------------------

                 Key: MIDEA-74
                 URL: http://jira.codehaus.org/browse/MIDEA-74
             Project: Maven 2.x Idea Plugin
          Issue Type: Bug
            Reporter: Remy Coqueugniot
         Attachments: IdeaModuleMojo.java

If a pom.xml include a dependency with a "provided" or "test" scope, it shouldn't be packaged
with the webapp.

Ex:
[pom.xml]
<project>
(...)
  <dependencies>

    <dependency>
      <groupId>javax.servlet</groupId>
      <artifactId>servlet-api</artifactId>
      <version>2.4</version>
      <scope>provided</scope>
    </dependency>

    <dependency>
      <groupId>junit</groupId>
      <artifactId>junit</artifactId>
      <version>3.8.1</version>
      <scope>test</scope>
    </dependency>

  </dependencies>
</project>

This two depndency shouldn't be included in the webapp/WEB-INF/lib. Indeed, some webcontainer
(tomcat for example) may crash (or ignore them) if libraries are already provided (servlet-api,
jsp-api, ...)

I've done some really basic tests and fix the IdeaModuleMojo class.

Hope you will find some utility.








-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message