maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dennis Lundberg (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MCHANGELOG-42) Changelog produces empty output.
Date Wed, 09 Aug 2006 18:11:09 GMT
    [ http://jira.codehaus.org/browse/MCHANGELOG-42?page=comments#action_71938 ] 
            
Dennis Lundberg commented on MCHANGELOG-42:
-------------------------------------------

First of all you need to change the groupId/artifactId so that you are running the Apache
version of the plugin. The one stated in the pom is the old version from the mojo project.
Also, because the Apache version of the plugin has not been released yet you need to add a
version element. It should look like this:

<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-changelog-plugin</artifactId>
<version>2.0-SNAPSHOT</version>

You may need to add some configuration to your settings.xml if you haven't already. Please
see:
http://maven.apache.org/guides/development/guide-testing-development-plugins.html

Your log says that you have test failures. Can that be the cause of your trouble?

> Changelog produces empty output.
> --------------------------------
>
>                 Key: MCHANGELOG-42
>                 URL: http://jira.codehaus.org/browse/MCHANGELOG-42
>             Project: Maven 2.x Changelog Plugin
>          Issue Type: Bug
>    Affects Versions: 2.0-beta-1
>         Environment: Windows XP SP2 / maven-2.0.4 
>            Reporter: Abhijit Diwan
>
> I am trying to get changelog for my project and  the mvn site command generates empty
changelog output.
> Following is the scm section of my pom.xml
>     <scm>
>         <connection>scm:perforce:<PRIVACYHIDDEN>@fish:1678://EJB/ejb-dev/MavenCodeline</connection>
>     </scm>
> and the plugin section I have 
>             <plugin>
>                 <groupId>org.codehaus.mojo</groupId>
>                 <artifactId>changelog-maven-plugin</artifactId>
>                 <reportSets>
>                     <reportSet>
>                         <id>Perofrce report</id>
>                         <configuration>
>                             <type>range</type>
>                             <range>30</range>
>                         </configuration>
>                         <reports>
>                             <report>changelog</report>
>                             <report>file-activity</report>
>                             <report>dev-activity</report>
>                         </reports>
>                     </reportSet>
>                 </reportSets>
>             </plugin>
> I get following error when I generate  site using maven site command.
> [ERROR] There are test failures.
> [INFO] [site:site]
> [WARNING] Error loading report org.apache.maven.changelog.ChangeLogReport - Abst
> ractMethodError: canGenerateReport()
> [WARNING] Error loading report org.apache.maven.changelog.FileActivityReport - A
> bstractMethodError: canGenerateReport()
> [WARNING] Error loading report org.apache.maven.changes.ChangesMojo - AbstractMe
> thodError: canGenerateReport()
> [WARNING] Error loading report org.apache.maven.jira.JiraMojo - AbstractMethodEr
> ror: canGenerateReport()
> Is it something related to setting maven.changelog.factory to "org.apache.maven.perforcelib.PerforceChangeLogFactory".
But where do you set this value if this is what i need.
> Please help.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message