maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yuri Schimke (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MNGECLIPSE-172) Eclipse PDE seems slightly incompatible with plugin
Date Thu, 03 Aug 2006 16:22:01 GMT
     [ http://jira.codehaus.org/browse/MNGECLIPSE-172?page=all ]

Yuri Schimke closed MNGECLIPSE-172.
-----------------------------------

    Resolution: Duplicate

duplicate of MNGECLIPSE-106

> Eclipse PDE seems slightly incompatible with plugin
> ---------------------------------------------------
>
>                 Key: MNGECLIPSE-172
>                 URL: http://jira.codehaus.org/browse/MNGECLIPSE-172
>             Project: Maven 2.x Extension for Eclipse
>          Issue Type: Improvement
>    Affects Versions: 0.0.9
>            Reporter: Yuri Schimke
>         Assigned To: Eugene Kuleshov
>
> Eclipse PDE Rich Clients seem to have trouble when using the maven plugin.
> To actually build the client application it seems to need the dependency jars within
the project.  To get around this we use the dependency:copy-dependencies task.  However this
setup stops debugging from working. It also means you need to run mvn install for the other
projects each time before you copy the dependencies.
> In constrast, after applying the patch from MNGECLIPSE-59, non-PDE projects work brilliantly.
> I'm reporting this improvement for a number of reasons 1) in case others are facing the
same problem, 2) in case other have solved the same problem already and 3) in case it might
be something you guys can fix easily.
> You guys might be the best candidates to answer 2) since you presumably use Eclipse to
edit the maven2 plugin anyway.
> Another option might be to make each maven JAR a valid OSGI plugin, which is mainly a
couple of extra files in the JAR.  This could potentially be done with a MOJO that added the
default, most liberal OSGI settings into the JAR.  But this seems a bit extreme, and also
inflexible in the case of truly internal dependencies.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message