maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Felipe Leme (JIRA)" <>
Subject [jira] Commented: (MECLIPSE-94) Allow eclipse:eclipse to work on pom (and other) projects
Date Thu, 06 Jul 2006 21:30:22 GMT
    [ ] 

Felipe Leme commented on MECLIPSE-94:

Hi Stephen,

Yes, you're right, the original request was based on how the M2Book defined an integration-test
scenario. And to be honest, I don't remember how exactly the use case was, as we had gave
up that integration-test project (for lack of time). 

Anyway, by the time the issue was created, there wasn't yet a well-defined scenario for M2
integration tests; once such scenario is defined, this issue might be marked as won't fix
(or not :-).

-- Felipe

> Allow eclipse:eclipse to work on pom (and other) projects
> ---------------------------------------------------------
>          Key: MECLIPSE-94
>          URL:
>      Project: Maven 2.x Eclipse Plugin
>         Type: Improvement

>     Versions: 2.1
>     Reporter: Felipe Leme

> I'm creating a Java EE project based on the m2book (which I was reviewing; it's not available
yet...) and one of the projects is a pom-packaging project used for integration tests. According
to Vincent, currently this project must be a pom (in fact, I tried to set it as jar, but then
the test phase would be run anyway, which would cause the tests to fail), as it doesn't produces
a jar. But as it has java files (on the src/main/it/java directory), I tried to call eclipse:eclipse
but it fails, saying that "Not running eclipse plugin goal for pom project".
> For these scenarios, I think a propery would be enough. At first I thought something
about a 'force' or 'forceGeneration' property, would enough, which the code change being from:
>  if ( "pom".equals( packaging ) && eclipseProjectDir == null ) 
> to:
>  if (  "pom".equals( packaging ) && eclipseProjectDir == null && !forceGeneration
> Then I realized there is other place where the pom nature is checked:
>  if (  "pom".equals( packaging ) && eclipseProjectDir == null && !forceGeneration
> So, I think a better name for the property would be 'javaProject' and the change would
> final boolean isJavaProjectProperty = // read property; defaults to false...
>  if (  "pom".equals( packaging ) && eclipseProjectDir == null && !isJavaProjectProperty
> isJavaProject = isJavaProjectProperty || !"ear".equals( packaging ) && !"pom".equals(
packaging );
> If nobody objects and someone is willing to apply the changes, I can provide such patch
(with the proper test cases).
> -- Felipe
> PS: I'm assigning it to Vincent for now, as he 'dreamed' that such features already existed

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message