maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Duncan Jr (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MNG-2340) Incorrect dependency version downloaded
Date Fri, 02 Jun 2006 17:33:44 GMT
    [ http://jira.codehaus.org/browse/MNG-2340?page=comments#action_66503 ] 

Stephen Duncan Jr commented on MNG-2340:
----------------------------------------

It appears that while "mvn package" uses the correct dependency, the dependencies report when
running "mvn site" also uses the incorrect version from dependencyManagement.

> Incorrect dependency version downloaded
> ---------------------------------------
>
>          Key: MNG-2340
>          URL: http://jira.codehaus.org/browse/MNG-2340
>      Project: Maven 2
>         Type: Bug

>   Components: Embedding
>     Versions: 2.0.4
>     Reporter: Adrian
>     Assignee: Jason van Zyl
>     Priority: Critical
>  Attachments: MNGECLIPSE-131.zip
>
>
> I have a parent pom with a dependency management section specifying the version of an
artifact to use. In the child project, I override this version.
> The maven plugin ignores the overriding version and downloads the version specified by
the parent pom.
> For example, in the parent pom
> {code}
> <dependency>
>       <groupId>lucene</groupId>
>       <artifactId>lucene</artifactId>
>       <version>1.4.3</version>
> </dependency>
> {code}
> in the project pom, inheriting the parent pom
> {code}
> <dependency>
>       <groupId>lucene</groupId>
>       <artifactId>lucene</artifactId>
>       <version>2.0</version>
> </dependency>
> {code}
> The maven eclipse plugin downloads version 1.4.3 for my project

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message