maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephane Nicoll (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MEAR-27) ejbModules not included in application.xml
Date Mon, 08 May 2006 18:42:41 GMT
     [ http://jira.codehaus.org/browse/MEAR-27?page=all ]
     
Stephane Nicoll closed MEAR-27:
-------------------------------

     Assign To: Stephane Nicoll
    Resolution: Cannot Reproduce

Can't reproduce. Please reopen with a step-by-step procedure to reproduce your problem.

Thanks.

> ejbModules not included in application.xml
> ------------------------------------------
>
>          Key: MEAR-27
>          URL: http://jira.codehaus.org/browse/MEAR-27
>      Project: Maven 2.x Ear Plugin
>         Type: Bug

>  Environment: Windows XP
>     Reporter: Tom Cunningham
>     Assignee: Stephane Nicoll

>
>
> The problem I'm seeing is that the plugin is generating two different application.xml's
and the one that gets stuck into the ear doesn't seem correct.    The one that gets stuck
into the ear doesn't give any entries for the ejbModules I have defined.
> My project has three dependencies and each should be a module in the application.xml.
   Here's what I have defined in my pom.xml :
> <dependencies>
>     <dependency>
>       <groupId>vfa</groupId>
>       <artifactId>facility-war</artifactId>
>       <version>8.0</version>
>       <type>war</type>
>     </dependency>
>     <dependency>
>       <groupId>vfa</groupId>
>       <artifactId>persistence</artifactId>
>       <scope>provided</scope>
>       <version>8.0</version>
>       <type>ejb</type>
>     </dependency>
>     <dependency>
>       <groupId>vfa</groupId>
>       <artifactId>facility</artifactId>
>       <version>8.0</version>
>       <type>ejb</type>
>     </dependency>
> </dependencies>
> <build>
>      <plugins>
>        <plugin>
> <groupId>org.apache.maven.plugins</groupId>
>         <artifactId>maven-ear-plugin</artifactId>
>         <configuration>
>   <modules>
>     <ejbModule>
> <groupId>vfa</groupId>
> <artifactId>facility</artifactId>
> <bundleDir>/</bundleDir>
>     </ejbModule>
>     <webModule>
> <groupId>vfa</groupId>
> <artifactId>facility-war</artifactId>
> <context-root>vfa</context-root>
>     </webModule>
>     <ejbModule>
> <groupId>vfa</groupId>
> <artifactId>persistence</artifactId>
> <bundleDir>/</bundleDir>
>     </ejbModule>
>   </modules>
>         </configuration>
>        </plugin>
> </plugins>
> When I run "maven install", I find an application.xml in the target directory that looks
okay to me:
> <?xml version="1.0" encoding="UTF-8"?>
> <!DOCTYPE application PUBLIC
>         "-//Sun Microsystems, Inc.//DTD J2EE Application 1.3//EN"
>         "http://java.sun.com/dtd/application_1_3.dtd">
> <application>
>   <display-name>facility-ear</display-name>
>   <module>
>     <ejb>facility-8.0.jar</ejb>
>   </module>
>   <module>
>     <web>
>       <web-uri>facility-war-8.0.war</web-uri>
>       <context-root>vfa</context-root>
>     </web>
>   </module>
>   <module>
>     <ejb>persistence-8.0.jar</ejb>
>   </module>
> </application>
> However, this isn't the application.xml that gets into the ear.    The  one going into
the ear
> has no ejb modules defined.
> <?xml version="1.0" encoding="UTF-8"?>
> <application version="1.4" xmlns="http://java.sun.com/xml/ns/j2ee" xmlns:xsi="ht
> tp://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com
> /xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/application_1_4.xsd">
> <description>Facility Prototype</description>
> <display-name>Facility Prototype</display-name>
> <module>
> <web>
> <web-uri>facility-war-8.0.war</web-uri>
> <context-root>/vfa</context-root>
> </web>
> </module>
> </application>

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message