maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Perham (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MSITE-142) Velocity verbosity errors
Date Tue, 23 May 2006 21:28:40 GMT
    [ http://jira.codehaus.org/browse/MSITE-142?page=comments#action_65755 ] 

Mike Perham commented on MSITE-142:
-----------------------------------

Frank, it is recommended that you open a new issue for each different error.  Don't report
multiple bugs in a single JIRA issue because then it is hard to categorize and track each
individual problem.  I'm not sure there's enough context for the archetype problem to be resolved.

> Velocity verbosity errors
> -------------------------
>
>          Key: MSITE-142
>          URL: http://jira.codehaus.org/browse/MSITE-142
>      Project: Maven 2.x Site Plugin
>         Type: Bug

>     Versions: 2.0-beta-5
>  Environment: Linux
>     Reporter: Frank Gutierrez
>     Priority: Trivial

>
>
> This bug is about the importance of Maven's first impression.  I'm a new user trying
to follow the procedure in the book (better builds with maven) .  I had two issues that made
me wonder about the stability of the product.  I love the ideas behind maven and I would hate
to see the progress of the product slowed due to a bad first impression.  
> #1) When issuing the archetype command it stopped in the middle of the procedure without
an error message.  I re-issued the command and it worked the second time around. 
>        $ mvn archetype:create -DgroupId=com.mycompany.app -DartifactId=my-app
> #2) When issuing the command "mvn site"  there are ERROR messages that appear on the
screen, again making me wonder about the stability of the product.  See section of output
below:
> [INFO] Velocimacro : initialization starting.
> [INFO] Velocimacro : adding VMs from VM library template : VM_global_library.vm
> [ERROR] ResourceManager : unable to find resource 'VM_global_library.vm' in any resource
loader.
> [INFO] Velocimacro : error using  VM library template VM_global_library.vm : org.apache.velocity.exception.ResourceNotFoundException:
Unable to find resource 'VM_global_library.vm'
> [INFO] Velocimacro :  VM library template macro registration complete.
> [INFO] Velocimacro : allowInline = true : VMs can be defined inline in templates
> [INFO] Velocimacro : allowInlineToOverride = false : VMs defined inline may NOT replace
previous VM definitions
> [INFO] Velocimacro : allowInlineLocal = false : VMs defined inline will be  global in
scope if allowed.
> [INFO] Velocimacro : initialization complete.
> [INFO] Velocity successfully started.
> [INFO] [site:site]
> [INFO] Generate "Continuous Integration" report.
> [ERROR] VM #displayTree: error : too few arguments to macro. Wanted 2 got 0
> [ERROR] VM #menuItem: error : too few arguments to macro. Wanted 1 got 0
> [INFO] Generate "Dependencies" report.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message