maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Behrang Saeedzadeh <behran...@gmail.com>
Subject Re: New PR: Enabled generating Java 9+ projects as well as using JUnit 5.x
Date Sat, 15 Jun 2019 14:08:56 GMT
The archetype doesn't depend on Java 8 or later -- it only produces
`pom.xml` files that are configured for Java 8, 9, etc.

Best regards,
Behrang Saeedzadeh
blog.behrang.org


On Sat, 15 Jun 2019 at 23:51, Tibor Digana <tibordigana@apache.org> wrote:

> .. but this java 1.7 project and not 1.8 you you have guessed.
>
> On Sat, Jun 15, 2019 at 3:07 PM Behrang Saeedzadeh <behrangsa@gmail.com>
> wrote:
>
> > Enabled generating Java 9+ projects as well as using JUnit 5.x
> >
> > I have kept the plugin backwards compatible -- if javaCompilerVersion and
> > junitVersion properties are not passed to the plugin it will work as
> before
> > and generate a Java 1.8 project with JUnit 4.11.
> >
> > https://github.com/apache/maven-archetypes/pull/3
> >
> >
> >
> > Best regards,
> > Behrang Saeedzadeh
> > blog.behrang.org
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message