maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tibor Digana <tibordig...@apache.org>
Subject ASM library not compatible with plexus-java:0.9.3 in Maven build
Date Sun, 06 May 2018 11:13:33 GMT
We have a problem [1] with old version of plexus-java:0.9.3 and ASM library.
We should use plexus-java:0.9.7 which is dependent on ASM 6.1.1.
This would fix our problem with Maven 3.5.3. But is it working solution for
older Maven versions too?

What would be a generic solution?
Would be Maven dependent on ASM?
I see currently versions of maven plugins would be related to certain maven
version due to ASM.

[1]: https://github.com/junit-team/junit5/issues/1409

Cheers
Tibor

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message