maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylwester Lachiewicz <slachiew...@gmail.com>
Subject Upgrade plugins to Maven 3 - min required Maven version
Date Thu, 18 Jan 2018 14:34:13 GMT
Hi dev,

As a test, I am trying to run plug-in updates in the maven-resolver mode
and I received an error message indicating that required runtime Maven
version is lower than required for plug-in.

I have a question, which version of Maven should I set required as a
minimum when upgrading plugins for Maven 3? Can I set 3.0.0 or 3.0.5 to
align with the current Maven 3.5?
For apache / maven I received the same message.

Best regards,
Sylwester
---

[INFO] --- versions-maven-plugin:2.6-SNAPSHOT:display-plugin-updates
(default-cli) @ maven-resolver ---
[INFO]
 [..]
[INFO]
[INFO] Project inherits minimum Maven version as: 3.0
[INFO] Plugins require minimum Maven version of: 3.0.4
[INFO] Note: the super-pom from Maven 3.5.3-SNAPSHOT defines some of the
plugin
[INFO]       versions and may be influencing the plugins required minimum
Maven
[INFO]       version.
[INFO]
[ERROR] Project requires an incorrect minimum version of Maven.
[ERROR] Update the pom.xml to contain maven-enforcer-plugin to
[ERROR] force the maven version which is needed to build this project.
[ERROR] See
https://maven.apache.org/enforcer/enforcer-rules/requireMavenVersion.html
[ERROR] Using the minimum version of Maven: 3.0

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message