maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Osipov <micha...@apache.org>
Subject Re: I think we are ready for 3.5.0-alpha-1
Date Fri, 17 Feb 2017 18:10:47 GMT
Am 2017-02-17 um 18:03 schrieb Arnaud Héritier:
> Is there someone who tried to deploy a "large" artifact ?
>
> I have a bug in 3.5 and not in 3.3.9 but for now no time to dig
>
> The project : https://github.com/jenkinsci/maven-plugin
> Downloading:
> https://repo.jenkins-ci.org/snapshots/org/jenkins-ci/main/maven-plugin/2.16-SNAPSHOT/maven-metadata.xml
> Downloaded:
> https://repo.jenkins-ci.org/snapshots/org/jenkins-ci/main/maven-plugin/2.16-SNAPSHOT/maven-metadata.xml
> (929 B at 1.5 kB/s)
> Uploading:
> https://repo.jenkins-ci.org/snapshots/org/jenkins-ci/main/maven-plugin/2.16-SNAPSHOT/maven-plugin-2.16-20170217.170023-3.hpi
> [INFO] I/O exception (java.net.SocketException) caught when processing
> request to {s}->https://repo.jenkins-ci.org:443: Broken pipe (Write failed)
> [INFO] Retrying request to {s}->https://repo.jenkins-ci.org:443
> [INFO] I/O exception (java.net.SocketException) caught when processing
> request to {s}->https://repo.jenkins-ci.org:443: Broken pipe (Write failed)
> [INFO] Retrying request to {s}->https://repo.jenkins-ci.org:443
> [INFO] I/O exception (java.net.SocketException) caught when processing
> request to {s}->https://repo.jenkins-ci.org:443: Broken pipe (Write failed)
> [INFO] Retrying request to {s}->https://repo.jenkins-ci.org:443

In Wagon 2.12 Apache HttpComponents have been upgraded:
> diff --git a/wagon-providers/pom.xml b/wagon-providers/pom.xml
> index 1995fb7..e29dd55 100644
> --- a/wagon-providers/pom.xml
> +++ b/wagon-providers/pom.xml
> @@ -23,7 +23,7 @@ under the License.
>    <parent>
>      <groupId>org.apache.maven.wagon</groupId>
>      <artifactId>wagon</artifactId>
> -    <version>2.10</version>
> +    <version>2.12</version>
>      <relativePath>../pom.xml</relativePath>
>    </parent>
>
> @@ -50,12 +50,12 @@ under the License.
>        <dependency>
>          <groupId>org.apache.httpcomponents</groupId>
>          <artifactId>httpclient</artifactId>
> -        <version>4.3.5</version>
> +        <version>4.5.2</version>
>        </dependency>
>        <dependency>
>          <groupId>org.apache.httpcomponents</groupId>
>          <artifactId>httpcore</artifactId>
> -        <version>4.3.2</version>
> +        <version>4.4.4</version>
>        </dependency>
>        <dependency>
>          <groupId>org.apache.sshd</groupId>

Additionally, the log dependencies where incorrectly configured which 
has been corrected in another ticket.

Finally, we have a HugeFileDownloadTest which downloads a 4 GiB large 
file, we can easily add a HugeFileUploadTest.

Looking at the log messages issued by the HttpComponents, you have a 
network issue. Somewhere between you and the Artifactory instance the 
connection has been terminated (broken pipe).

Can you repeat this issue realiably?

Michael



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message