maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prakul Agarwal <prak...@uci.edu>
Subject Method level parallelization not completing consistently
Date Fri, 09 Sep 2016 18:00:00 GMT
Hi,

Using Maven 3.3.9, maven-eclipse-plugin 2.9, failsafe 2.19.1, surefire
2.19.1.

I'm using FailSafe parallel = method and threadCount ={5,10,50,100} to
execute a bunch of test classes with forkCount = {2,3,4,5}. The
integration-test phase is completing sometimes and getting stuck for long
the other times. When it is getting stuck it is taking > 20 min than normal
execution to complete.

In case when tests are getting stuck I notice that the log files
(failsafe-reports folder) of individual test classes are generated each
time consistently but the summary file generation does't happens for long.
Also one surefire-booter jvm lingers on while others are killed.

When I execute in with forkCount = 1 the test execution probably doesnt
start at all (Failsafe-reports folder is not generated, surefire tmp files
are ). If I reduce the number of test classes to be executed (with
forkCount = 1) then the execution is completing normally. We have ~100 test
classes with ~1000 test methods to be executed.

I'm using reuseForks = true and have tried execution after removing all
fork related settings.

Can anyone suggest why this extension is not executing consistently.

Thanks ,

Other configuration:

OS name: "mac os x", version: "10.11.6", Intel 2.8 GHz i7, 16GB DDR3 RAM.

JDK 1.7.0_8

-- 
Prakul Agarwal

M.S. Computer Science | University of California, Irvine, Dec '16

Ph: (949)372-8510
Linkedin: https://www.linkedin.com/in/prakulagarwal

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message