maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Schulte ...@schulte.it>
Subject Re: POM Model version 4.1.0 in 3.4.0-SNAPSHOTs
Date Tue, 23 Aug 2016 12:01:20 GMT
Am 08/23/16 um 01:12 schrieb Stephen Connolly:
> On Monday 22 August 2016, Christian Schulte <cs@schulte.it> wrote:
>> That won't scale. What is to note here is that the XML schema or
>> anything syntax does not change between 4.0.0 and 4.1.0. It's just that
>> Maven 3.4 performs the dependency management import differently when
>> operating on a 4.1.0 POM instead of a 4.0.0 POM.
> 
> 
> But what happens when maven [2.0-3.3.4) download that Pom?
> 
> If the answer is "blow up" then I am -1

Blow up. Correct. What else should it do? It cannot provide the same
effective model 3.4+ does. So either it produces incorrect effective
models leading to build failures later on or it just stops informing the
user that a more recent maven version is needed. Same for the include
scope. 3.4+ supports it. Older versions start producing incorrect
effective models. The whole import scope feature has been introduced
between Maven 2.0.8 and 2.0.9. No one complained about an older Maven
version not supporting that scope. Situation today is different. I know.
Even the IDE of my choice still bundles Maven 3.0.5. I am more in favour
of adding that include scope right now. Projects using that scope take
the "you need to build/consume this using 3.4+" burden. They will be the
ones receiving huge amounts of build failure reports this way because
older Maven versions simply do not process those dependency management
includes which will make most of those projects blow up as well when not
using 3.4+.

Regards,
-- 
Christian


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message