maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabio Tudone (fabio@paralleluniverse.co)" <fa...@paralleluniverse.co>
Subject [Aether] Result of resolution request w/conflict res. contains conflicting transitive deps.
Date Wed, 06 Apr 2016 07:22:49 GMT
Hi,

I posted this on the aether mailing list already but it doesn't seem very active so I'd ask
here too, especially considering https://projects.eclipse.org/projects/technology.aether/reviews/termination-review
(I also opened an issue about that: https://bugs.eclipse.org/bugs/show_bug.cgi?id=490962).
I apologize in advance if this is not the right place to ask, in that case could someone point
to the right one?. TIA.

--

Conflict resolution seems not to work correctly in my case (but I'm no Aether expert). It
can be tried out by cloninghttps://github.com/circlespainter/capsule-maven-13, which is meant
to reproduce more easilyhttps://github.com/puniverse/capsule-maven/issues/13, and running
`gradlew run`.

Shortly: I'm using a "RepositorySystemSession" built from "MavenRepositorySystemUtils" ("maven-aether-provider");
I tried both by explicitly setting a " ConflictResolver" graph transformer that includes a
"NearestVersionSelector" and by not setting it (it looks like it is already setup in this
way by "MavenRepositorySystemUtils.newSession") so I'd expect Aether to resolve automatically
a conflict between "org.slf4j:slf4j-api" 1.7.18 and 1.7.19, which are transitive dependencies
of my resolution request about "ch.qos.logback:logback-classic:1.1.6" and "org.slf4j:slf4j-simple:1.7.19"
resp.

This doesn't seem to happen though (I get both), and I don't understand why. The versions
I tried are " 1.0.2.v20150114" and "1.1" for Aether and " 3.3.3" and "3.3.3" for "maven-aether-provider".

Any help will be greatly appreciated!

Thanks,
-- Fabio


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message