maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Gudian <andreas.gud...@gmail.com>
Subject Re: [DISCUSS] Java version requirement for Mavan 3.4.x
Date Mon, 14 Dec 2015 20:41:15 GMT
> JUnit 4 End Of Life
>
> I have a strong reason to use Java 8 in Surefire project.
> For more information read this
> https://github.com/junit-team/junit-lambda/issues/31


Hi Tibor,

Wouldn't it be enough to only build the new Junit-5 provider with
source/target level 8 (if that would even be necessary) and switch the
animal-sniffer to JDK 8 signatures only for that module? Or move that
provider to its own repository with its own JDK 8 build...

In any case, I don't think we'd have a strict requirement to move all of
surefire to Java 8 bytecode only because of a new test provider - or a
dependency thereof. Sure it would be cool to go full Java 8 in Surefire,
but I don't think we can or should pull that off.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message