maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kristian Rosenvold <kristian.rosenv...@gmail.com>
Subject Re: [DISCUSS] Java version requirement for Mavan 3.4.x
Date Wed, 02 Dec 2015 09:15:18 GMT
2015-12-02 9:38 GMT+01:00 Stephen Connolly <stephen.alan.connolly@gmail.com>
:

> If we look at our JVM company history, IIRC
>
> 2.0 = Java 1.4
> 2.1 = Java 1.4
> 2.2 = Java 1.5
> 3.0 = Java 1.5
> 3.1 = Java 1.6
> 3.2 = Java 1.6
> 3.3 = Java 1.7
>
>
It looks like 3.4 will be 1.7 and 3.5 1.8 :)

Having worked with 1.8 since long before the official release , I'd just
like to point out that 1.8 really does not change much regarding maven
core. it will really only affect a handful of people actually writing code
within maven core. So there is really very little reason to be overly
aggressive in upgrading (unless we think it can attract people to work on
core). I also doubt very much that we'll be adding that many
lambda-specific api's to maven core any time soon. There'll probably be
various function-oriented method popping up in shared code and other libs,
but that's quite some time off.

Stephen's comments about overall tool support for 1.6 is probably the most
important thing here. I suspect the length of our stay on 1.6 minimum for
plugins will be very very short. So I'd say move core to 1.8 and all
plugins to 1.7 in 6 months time.

Kristian

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message