maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Derricutt" <m...@talios.com>
Subject Re: [DISCUSS] Java version requirement for Mavan 3.4.x
Date Tue, 01 Dec 2015 09:15:25 GMT
On 1 Dec 2015, at 20:10, Kristian Rosenvold wrote:

> If we are to stay aligned with current practice, jdk8 should be a
> minor release. As for the actual topic of "should" we switch, i'm
> always in favour of moving forwards. But not in any religious sense.

Minor or patch?  i.e 3.3.9 is current, would this be say 3.3.10, or 3.4.1?

Just RUNNING under JDK8 explodes horribly for us on some of our modules ( still requiring
antlr 3 - which is known to just not run under JDK8 ).

So if a release required changing JDKs and then broke builds - that's definitely not a patch
release, but I'd also be hesitant over a minor release.

Toolchains are great - IF plugins actually support them, which is what - 4 maybe 5 plugins
in total? Sadly not many plugins fork a separate process to run let alone support tool chains.



-- 
Mark Derricutt
http://www.theoryinpractice.net
http://www.chaliceofblood.net
http://plus.google.com/+MarkDerricutt
http://twitter.com/talios
http://facebook.com/mderricutt

Mime
View raw message