maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Heinz Marbaise <khmarba...@gmx.de>
Subject CI core-it-maven
Date Sat, 12 Dec 2015 17:05:30 GMT
Hi,

after looking into the integration tests based on removing the Ant build 
i have observed a strange thing...

The following:
https://builds.apache.org/view/M-R/view/Maven/job/core-it-maven-3-win/1045/consoleFull

is finished successfully whereas

https://builds.apache.org/view/M-R/view/Maven/job/core-it-maven-3-win/1044/consoleFull

is not finished successfully...

The only difference is that #1045 uses Maven 3.3.1 for running the 
integration tests..and #1044 uses Maven 3.0.5..

i have dived a little bit more into this and checked the bootstrap 
output during the start of the integration tests which uses mvn 
dependency:resolve-plugins which misses some artifacts:

http://localhost:8081/nexus/content/groups/public/org/apache/maven/maven-plugin-parameter-documenter/2.0.6/maven-plugin-parameter-documenter-2.0.6.pom

and the running of the integration test fails on the missing for such 
artifact..During the bootstrap maven-plugin-parameter-documenter-2.0.9 
will be downloaded...but the integration test mng-5898 will try to get 
maven-plugin-parameter-documenter-2.0.6...



If i use Maven 3.3.1 for the integration tests the tests will work fine...

Someone an idea? what could be the root cause?...


Kind regards
Karl Heinz Marbaise

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message