maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arnaud Héritier <aherit...@gmail.com>
Subject Re: maven git commit: [MNG-5905] Maven build does not work with Maven 2.2.1 Added maven-enforcer rule to check the minimum Maven version to be built with.
Date Wed, 07 Oct 2015 16:46:15 GMT
I’m surprised we didn’t yet have configured the enforcer plugin to validate the JDK version
to use to build ?
Or maybe it is done in our parent from the value of maven.compiler.target ?

> On 07 Oct 2015, at 17:30, khmarbaise@apache.org wrote:
> 
> Repository: maven
> Updated Branches:
>  refs/heads/master 8a51f9e51 -> bcacea2cf
> 
> 
> [MNG-5905] Maven build does not work with Maven 2.2.1
> Added maven-enforcer rule to check the minimum Maven version
> to be built with.
> 
> 
> Project: http://git-wip-us.apache.org/repos/asf/maven/repo
> Commit: http://git-wip-us.apache.org/repos/asf/maven/commit/bcacea2c
> Tree: http://git-wip-us.apache.org/repos/asf/maven/tree/bcacea2c
> Diff: http://git-wip-us.apache.org/repos/asf/maven/diff/bcacea2c
> 
> Branch: refs/heads/master
> Commit: bcacea2cfb9702658914a40a95251f2d8335b3f5
> Parents: 8a51f9e
> Author: Karl Heinz Marbaise <khmarbaise@apache.org>
> Authored: Wed Oct 7 17:28:31 2015 +0200
> Committer: Karl Heinz Marbaise <khmarbaise@apache.org>
> Committed: Wed Oct 7 17:30:04 2015 +0200
> 
> ----------------------------------------------------------------------
> pom.xml | 25 ++++++++++++++++++++++++-
> 1 file changed, 24 insertions(+), 1 deletion(-)
> ----------------------------------------------------------------------
> 
> 
> http://git-wip-us.apache.org/repos/asf/maven/blob/bcacea2c/pom.xml
> ----------------------------------------------------------------------
> diff --git a/pom.xml b/pom.xml
> index 75cb34e..0058334 100644
> --- a/pom.xml
> +++ b/pom.xml
> @@ -42,6 +42,7 @@
>   <inceptionYear>2001</inceptionYear>
> 
>   <properties>
> +    <maven.version>3.0.5</maven.version>
>     <maven.compiler.source>1.7</maven.compiler.source>
>     <maven.compiler.target>1.7</maven.compiler.target>
>     <classWorldsVersion>2.5.2</classWorldsVersion>
> @@ -142,8 +143,11 @@
>     </contributor>
>   </contributors>
> 
> +  <!-- This marked as deprecated for Maven 3.X. This is checked by maven-enforcer-plugin
-->
> +  <!--  http://jira.codehaus.org/browse/MNG-4840 -->
> +  <!--  http://jira.codehaus.org/browse/MNG-5297 -->
>   <prerequisites>
> -    <maven>2.2.1</maven>
> +    <maven>${maven.version}</maven>
>   </prerequisites>
> 
>   <!--bootstrap-start-comment-->
> @@ -559,6 +563,25 @@
>           </excludes>
>         </configuration>
>       </plugin>
> +      <plugin>
> +        <groupId>org.apache.maven.plugins</groupId>
> +        <artifactId>maven-enforcer-plugin</artifactId>
> +        <executions>
> +          <execution>
> +            <id>enforce-maven</id>
> +            <goals>
> +              <goal>enforce</goal>
> +            </goals>
> +            <configuration>
> +              <rules>
> +                <requireMavenVersion>
> +                  <version>${maven.version}</version>
> +                </requireMavenVersion>
> +              </rules>    
> +            </configuration>
> +          </execution>
> +        </executions>
> +      </plugin>
>     </plugins>
>   </build>
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message