maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Heinz Marbaise <khmarba...@gmx.de>
Subject Re: Maven Release Plugin with Git broken?
Date Wed, 07 Oct 2015 07:23:14 GMT
Hi Robert,

Is this  a mult module project ? Have you defined the scm connection 
only in the root module ? Are you trying to release from the root of ?

Kind regards
Karl Heinz Marbaise

On 10/7/15 4:48 AM, Robert Patrick wrote:
> Hi,
>
>
>
> Sorry for the noise but it seems like the Maven Release Plugin 2.5.2 (with Maven 3.3.3)
is not doing what I would have expected with a Git repo.  As you can see below, the "git push"
command is mangling the repository by tacking the artifactId of my multi-module project onto
the end of the connection url, which is causing our Gitlab server to rightfully complain that
the repository does not exist.
>
>
>
> [INFO] Checking in modified POMs...
>
> [INFO] Executing: /bin/sh -c cd /scratch/rpatrick/snapshots-test && git add --
parent/pom.xml util/pom.xml consumer/pom.xml pom.xml
>
> [INFO] Working directory: /scratch/rpatrick/snapshots-test
>
> [INFO] Executing: /bin/sh -c cd /scratch/rpatrick/snapshots-test && git rev-parse
--show-toplevel
>
> [INFO] Working directory: /scratch/rpatrick/snapshots-test
>
> [INFO] Executing: /bin/sh -c cd /scratch/rpatrick/snapshots-test && git status
--porcelain .
>
> [INFO] Working directory: /scratch/rpatrick/snapshots-test
>
> [INFO] Executing: /bin/sh -c cd /scratch/rpatrick/snapshots-test && git commit
--verbose -F /tmp/maven-scm-1310627247.commit parent/pom.xml util/pom.xml consumer/pom.xml
pom.xml
>
> [INFO] Working directory: /scratch/rpatrick/snapshots-test
>
> [INFO] Executing: /bin/sh -c cd /scratch/rpatrick/snapshots-test && git symbolic-ref
HEAD
>
> [INFO] Working directory: /scratch/rpatrick/snapshots-test
>
> [INFO] Executing: /bin/sh -c cd /scratch/rpatrick/snapshots-test && git push
git@orahub.oraclecorp.com:robert.patrick/snapshots-test.git/snapshots-multi-module refs/heads/master:refs/heads/master
>
>
>
> My scm section of my parent pom (whjch all poms inherent from) looks like this:
>
>
>
>    <scm>
>      <developerConnection>scm:git:git@orahub.oraclecorp.com:robert.patrick/snapshots-test.git</developerConnection>
>      <connection>scm:git:git@orahub.oraclecorp.com:robert.patrick/snapshots-test.git</connection>
>    </scm>
>
>
>
> So why is Maven trying to use HYPERLINK "mailto:git@orahub.oraclecorp.com:robert.patrick/snapshots-test.git/snapshots-multi-module"git@orahub.oraclecorp.com:robert.patrick/snapshots-test.git/snapshots-multi-module
in the git push command?
>
>
>
> Am I just doing something stupid or is this really busted?
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message