maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Heinz Marbaise <khmarba...@gmx.de>
Subject Re: Suggestions User Information about Maven 2.2.1 EoL / Plugins / JDK
Date Thu, 19 Mar 2015 19:02:03 GMT
Hi,

nothing more to improve ?

Kind regards
Karl Heinz Marbaise
On 3/18/15 10:21 PM, Karl Heinz Marbaise wrote:
> Hi,
>
> i have incorporated the suggestions/ideas/improvements....
>
> https://github.com/khmarbaise/maven2eol/blob/master/message.txt
>
>
> If you have adds/supplementals/etc. please send a pull request or you
> can create an issue...
>
>
> The list of Maven versions / JDK requirements should be listed on the
> download page...IMHO...
>
> Kind regards
> Karl Heinz Marbaise
>
>
> On 3/5/15 7:35 PM, Karl Heinz Marbaise wrote:
>> Hi,
>>
>> here is my suggestions for the user list announcement regarding Maven
>> 2.2.1 EoL / Plugins version lift / JDK etc.
>>
>> Any enhancement / things which should also be mentioned please reply and
>> make appropriate changes / Thinks which i have missed...
>>
>>
>> -------------------------------------------------------------
>> Dear Maven Users,
>>
>> based on the End of Life of Maven 2.2.1 (a year ago) now the time has
>> come to make the final releases of Apache Maven Plugins which support
>> Maven 2.X.
>>
>> We have documented the final releases of plugins which support Maven
>> 2.2.1 in relationship with JDK 1.5
>>
>> The complete list can be found here:
>>
>> http://maven.apache.org/maven-2.x-eol.html
>>
>> The next step on our roadmap is to lift all plugin versions to 3.X to
>> make clear those plugins will only work with Maven 3.0+ furthermore the
>> Java minimum requirement will lifted to JDK 1.6 as well.
>>
>> No "rule" without exceptions. Here they come:
>>
>>
>>   * maven-site-plugin (Version 3.4)
>>     See the docs of the plugin for usage in Maven 2.X
>>
>>   * maven-compiler-plugin (Version 3.2)
>>     which works with Maven 2.2.1.
>>
>>   * maven-plugin-plugin (Version 3.4)
>>     which works with Maven 2.2.1
>>
>>   * maven-pmd-plugin (Version 3.4)
>>     which works with Maven 2.2.1 but needs JDK 1.6
>>
>>
>> The following plugins already have the Maven 3.0+ requirement:
>>
>> * maven-scm-publish-plugin (Version 1.1)
>> * maven-shade-plugin (Version 2.3)
>>
>>
>> So to make things more clearer here is an example:
>>
>> Currently we have the maven-clean-plugin with version 2.6.1.
>>
>> This plugin supports Maven 2.2.1 and JDK 1.5 minimum.
>>
>> This plugin will get a new major release with version 3.0 which has the
>> Maven minimum 3.0 AND Jave minimum 1.6.
>>
>>
>> Kind regards
>> The Apache Maven Team
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message