maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hervé BOUTEMY <herve.bout...@free.fr>
Subject Re: Suggestions User Information about Maven 2.2.1 EoL / Plugins / JDK
Date Mon, 09 Mar 2015 02:35:16 GMT
Hi,

I tried improvements on http://maven.staging.apache.org/maven-2.x-eol.html

And here are some small updates proposed to the announcement: the newest idea 
is that plugins already at 3.x will switch to Maven 3 prerequisite for 
plugin's version 3.5 (see compiler which should go from 3.2 to 3.5 to follow 
the pattern)

Regards,

Hervé

Le jeudi 5 mars 2015 19:35:04 Karl Heinz Marbaise a écrit :
> Hi,
> 
> here is my suggestions for the user list announcement regarding Maven
> 2.2.1 EoL / Plugins version lift / JDK etc.
> 
> Any enhancement / things which should also be mentioned please reply and
> make appropriate changes / Thinks which i have missed...
> 
> 
-------------------------------------------------------------
Dear Apache Maven Users,

Based on the End of Life of Maven 2.2.1 (a year ago), now the time has 
come to make the final releases of Apache Maven Plugins which support 
Maven 2.X: next releases will have Maven 3 as prerequisite.

We have documented the final releases of plugins which support Maven 
2.2.1 and Java 5: the complete list can be found here:

http://maven.apache.org/maven-2.x-eol.html

The next step on our roadmap is to lift all plugin versions to 3.X in general 
to make clear those plugins will only work with Maven 3.0+. Furthermore the 
Java minimum requirement will be lifted to Java 6 as well.

No "rule" without exceptions. Here they come:


  * maven-site-plugin: version 3.4 works with Maven 2.X
    Version 3.5 will require Maven 3

  * maven-compiler-plugin: version 3.2 works with Maven 2.X
    Version 3.5 will require Maven 3

  * maven-plugin-plugin: version 3.4 works with Maven 2.X
    Version 3.5 will require Maven 3

  * maven-pmd-plugin: version 3.4  works with Maven 2.X but already requires
   Java 6
    Version 3.5 will require Maven 3


The following plugins already have the Maven 3.0+ requirement without 
following 3.X version pattern:

* maven-scm-publish-plugin: version 1.1 requires Maven 3, last version 
compatible with Maven 2.x is version 1.0-beta-2

* maven-shade-plugin: version 2.3 requires Maven 3, last version compatible 
with Maven 2.x is version 1.7.1


So to make things more clear, here is an example:

Currently, we have the maven-clean-plugin with version 2.6.1.

This plugin supports Maven 2.2.1 and Java 5 minimum.

This plugin will get a new major release with version 3.0 which has Maven 3.0 
AND Java 6 prerequisites.


Kind regards
The Apache Maven Team

-------------------------------------------------------------


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message