maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Manfred Moser" <manf...@mosabuam.com>
Subject Re: [VOTE] Suggestions User Information about Maven 2.2.1 EoL / Plugins / JDK
Date Tue, 17 Mar 2015 17:34:58 GMT
Looks all good to me. The only thing I would potentially add is a stronger reference to the
fact that Maven 2.2 is EOL and completely unsupported and that even early 3.x releases are
following the way of the dodo so it is important to upgrade to a new Maven version if they
want to have access to new features and bug fixes.

manfred

Karl Heinz Marbaise wrote on 14.03.2015 06:09:

> Hi,
> 
> would like someone to add/change/enhancements or something to this....
> 
> i would suggest to wait the usual 72 hours and if no one will say -1  i 
> would prepare to send out this to users list, announcement 
> list...twitter...google plus etc. (any supplemtal channels are welcome)...
> 
> I would like to send this out on Thursday 19. march 2015...so we have a 
> little bit more time...to give others during the week time to take a 
> look on it as well...
> 
> > -------------------------------------------------------------
>> Dear Apache Maven Users,
>>
>> Based on the End of Life of Maven 2.2.1 (a year ago), now the time has
>> come to make the final releases of Apache Maven Plugins which support
>> Maven 2.X: next releases will have Maven 3 as prerequisite.
>>
>> We have documented the final releases of plugins which support Maven
>> 2.2.1 and Java 5: the complete list can be found here:
>>
>> http://maven.apache.org/maven-2.x-eol.html
>>
>> The next step on our roadmap is to lift all plugin versions to 3.X in general
>> to make clear those plugins will only work with Maven 3.0+. Furthermore the
>> Java minimum requirement will be lifted to Java 6 as well.
>>
>> No "rule" without exceptions. Here they come:
>>
>>
>>    * maven-site-plugin: version 3.4 works with Maven 2.X
>>      Version 3.5 will require Maven 3
>>
>>    * maven-compiler-plugin: version 3.2 works with Maven 2.X
>>      Version 3.5 will require Maven 3
>>
>>    * maven-plugin-plugin: version 3.4 works with Maven 2.X
>>      Version 3.5 will require Maven 3
>>
>>    * maven-pmd-plugin: version 3.4  works with Maven 2.X but already requires
>>     Java 6
>>      Version 3.5 will require Maven 3
>>
>>
>> The following plugins already have the Maven 3.0+ requirement without
>> following 3.X version pattern:
>>
>> * maven-scm-publish-plugin: version 1.1 requires Maven 3, last version
>> compatible with Maven 2.x is version 1.0-beta-2
>>
>> * maven-shade-plugin: version 2.3 requires Maven 3, last version compatible
>> with Maven 2.x is version 1.7.1
>>
>>
>> So to make things more clear, here is an example:
>>
>> Currently, we have the maven-clean-plugin with version 2.6.1.
>>
>> This plugin supports Maven 2.2.1 and Java 5 minimum.
>>
>> This plugin will get a new major release with version 3.0 which has Maven 3.0
>> AND Java 6 prerequisites.
>>
>>
>> Kind regards
>> The Apache Maven Team
>>
>> -------------------------------------------------------------
> 
> 
> 
> Kind regards
> Karl Heinz Marbaise
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message