maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benson Margulies <bimargul...@gmail.com>
Subject Re: Archetype looping sort of with Maven 3.2.5
Date Fri, 20 Feb 2015 13:36:32 GMT
Whoops. Ok, I will deal over the weekend
On Feb 20, 2015 8:26 AM, "Stuart McCulloch" <mcculls@gmail.com> wrote:

> I would, but I’m not a committer here ;)
>
> On Friday, 20 February 2015 at 13:15, Benson Margulies wrote:
>
> > I like your fix better than my fix, please feel free to commit the
> switch.
> >
> > On Fri, Feb 20, 2015 at 8:14 AM, Stuart McCulloch <mcculls@gmail.com
> (mailto:mcculls@gmail.com)> wrote:
> > > FYI, here’s the two competing classworld dependencies... one is the
> old classworlds:classworlds and the other
> org.codehaus.plexus:plexus-classworlds:
> > >
> > > [INFO] | +-
> org.codehaus.plexus:plexus-interactivity-api:jar:1.0-alpha-6:compile
> > > [INFO] | | \-
> org.codehaus.plexus:plexus-component-api:jar:1.0-alpha-16:compile
> > > [INFO] | | \-
> org.codehaus.plexus:plexus-classworlds:jar:1.2-alpha-7:compile <—
> plexus-classworlds
> > > [INFO] | +- org.apache.maven:maven-artifact-manager:jar:2.2.1:compile
> > > [INFO] | | \-
> backport-util-concurrent:backport-util-concurrent:jar:3.1:compile
> > > [INFO] | +- org.apache.maven:maven-monitor:jar:2.2.1:compile
> > > [INFO] | +- org.apache.maven.wagon:wagon-ssh:jar:1.0-beta-6:compile
> > > [INFO] | | \- com.jcraft:jsch:jar:0.1.38:compile
> > > [INFO] | +- classworlds:classworlds:jar:1.1:compile <— classworlds
> > > [INFO] | \- org.sonatype.plexus:plexus-sec-dispatcher:jar:1.3:compile
> > > [INFO] | \- org.sonatype.plexus:plexus-cipher:jar:1.4:compile
> > >
> > >
> > > Both are brought in as transitive dependencies of maven-core (2.2.1)
> > >
> > > If I add a test dependency to classworlds:classworlds:jar:1.1 at the
> top of the dependencies in maven-archetype-plugin/pom.xml, or add a test
> dependency to plexus-container-default (which has a transitive dependency
> to the old classworlds artifact) then the hang doesn’t occur… note that
> this is testing with 3.2.5 without making surefire fork and without adding
> more memory:
> > >
> > > diff --git a/maven-archetype-plugin/pom.xml
> b/maven-archetype-plugin/pom.xml
> > > index 921fdbb..3b9e0e5 100644
> > > --- a/maven-archetype-plugin/pom.xml
> > > +++ b/maven-archetype-plugin/pom.xml
> > > @@ -51,6 +51,11 @@
> > >
> > > <dependencies>
> > > <dependency>
> > > + <groupId>org.codehaus.plexus</groupId>
> > > + <artifactId>plexus-container-default</artifactId>
> > > + <scope>test</scope>
> > > + </dependency>
> > > + <dependency>
> > > <groupId>org.apache.maven.archetype</groupId>
> > > <artifactId>archetype-catalog</artifactId>
> > > </dependency>
> > >
> > >
> > >
> > > On Friday, 20 February 2015 at 12:48, Benson Margulies wrote:
> > >
> > > > Making surefire fork and giving it more memory did the job. Once we
> make
> > > > the 2.2.1 release we can presumably make archetype use non-antique
> plexus.
> > > > On Feb 20, 2015 7:46 AM, "Stuart McCulloch" <mcculls@gmail.com
> (mailto:mcculls@gmail.com)> wrote:
> > > >
> > > > > If I get time I can try to debug it this weekend - looking at the
> line
> > > > > numbers in the stack trace, the hang is happening inside the old
> container:
> > > > >
> > > > > at
> > > > >
> org.codehaus.plexus.component.discovery.AbstractComponentDiscoverer.findComponents(AbstractComponentDiscoverer.java:78)
> > > > >
> > > > >
> https://github.com/sonatype/plexus-containers/blob/plexus-container-default-1.0-alpha-9-stable-1/src/main/java/org/codehaus/plexus/component/discovery/AbstractComponentDiscoverer.java#L78
> > > > > at
> > > > >
> org.codehaus.plexus.DefaultPlexusContainer.discoverComponents(DefaultPlexusContainer.java:717)
> > > > >
> > > > >
> https://github.com/sonatype/plexus-containers/blob/plexus-container-default-1.0-alpha-9-stable-1/src/main/java/org/codehaus/plexus/DefaultPlexusContainer.java#L717
> > > > > at
> > > > >
> org.codehaus.plexus.DefaultPlexusContainer.start(DefaultPlexusContainer.java:779)
> > > > >
> > > > >
> https://github.com/sonatype/plexus-containers/blob/plexus-container-default-1.0-alpha-9-stable-1/src/main/java/org/codehaus/plexus/DefaultPlexusContainer.java#L779
> > > > >
> > > > > at
> org.codehaus.plexus.PlexusTestCase.setUp(PlexusTestCase.java:121)
> > > > >
> > > > >
> https://github.com/sonatype/plexus-containers/blob/plexus-container-default-1.0-alpha-9-stable-1/src/main/java/org/codehaus/plexus/PlexusTestCase.java#L121
> > > > > at
> > > > >
> org.apache.maven.archetype.ui.generation.DefaultArchetypeSelectionQueryerTest.setUp(DefaultArchetypeSelectionQueryerTest.java:44)
> > > > >
> > > > >
> > > > > Not sure why the old container gets into this state, maybe it’s
> the newer
> > > > > version of classworlds? Or maybe the test classpath needs some
> additional
> > > > > isolation/tweaking?
> > > > >
> > > > > Also note that if I run the test on its own
> > > > > (-Dtest=DefaultArchetypeSelectionQueryerTest) then it only takes
a
> second
> > > > > or so with 3.2.5.
> > > > >
> > > > > --
> > > > > Cheers, Stuart
> > > > >
> > > > >
> > > > > On Friday, 20 February 2015 at 12:22, Benson Margulies wrote:
> > > > >
> > > > >
> org.codehaus.plexus.component.discovery.PlexusXmlComponentDiscoverer#discoverConfiguration
> > > > > >
> > > > > > Is 'discovering' 57 copies of
> > > > >
> jar:file:/Users/benson/.m2/repository/org/apache/maven/maven-core/2.2.1/maven-core-2.2.1.jar!/META-INF/plexus/plexus.xml.
> > > > > >
> > > > > > Reading it over and over is taking a long time. As previously
> > > > > > documented, using a newer copy of plexus leads to problems.
> > > > > >
> > > > > >
> > > > > >
> > > > > > On Fri, Feb 20, 2015 at 6:51 AM, Benson Margulies <
> bimargulies@gmail.com (mailto:bimargulies@gmail.com)
> > > > > (mailto:bimargulies@gmail.com)> wrote:
> > > > > > > What I see is:
> > > > > > >
> > > > > > > Tests run: 3, Failures: 0, Errors: 0, Skipped: 0, Time
> elapsed: 1.071
> > > > > > > sec - in
> > > > > > >
> > > > > >
> > > > >
> > > > >
> > > > >
> org.apache.maven.archetype.ui.generation.DefaultArchetypeGenerationConfiguratorTest
> > > > > > > Running
> > > > > >
> > > > >
> > > > >
> > > > >
> org.apache.maven.archetype.ui.generation.DefaultArchetypeSelectionQueryerTest
> > > > > > > Tests run: 5, Failures: 0, Errors: 0, Skipped: 0, Time
> elapsed: 55.357
> > > > > > > sec - in
> > > > > > >
> > > > > >
> > > > >
> > > > >
> > > > >
> org.apache.maven.archetype.ui.generation.DefaultArchetypeSelectionQueryerTest
> > > > > > > Running
> > > > > >
> > > > >
> > > > >
> > > > >
> org.apache.maven.archetype.ui.generation.DefaultArchetypeSelectorTest
> > > > > > > ...
> > > > > > >
> > > > > > > So it appears that DefaultArchetypeSelectorTest gets lost
in a
> loop.
> > > > > > > Hervé, have you poked further?
> > > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> ---------------------------------------------------------------------
> > > > > > To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> (mailto:dev-unsubscribe@maven.apache.org) (mailto:
> > > > > >
> > > > >
> > > > >
> > > > > dev-unsubscribe@maven.apache.org (mailto:
> dev-unsubscribe@maven.apache.org))
> > > > > > For additional commands, e-mail: dev-help@maven.apache.org
> (mailto:dev-help@maven.apache.org) (mailto:
> > > > >
> > > > >
> > > > > dev-help@maven.apache.org (mailto:dev-help@maven.apache.org))
> > > > > >
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org (mailto:
> dev-unsubscribe@maven.apache.org)
> > For additional commands, e-mail: dev-help@maven.apache.org (mailto:
> dev-help@maven.apache.org)
> >
> >
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message