maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason van Zyl <ja...@takari.io>
Subject Re: Maven 3.2.6
Date Sat, 28 Feb 2015 15:37:36 GMT
Great, thanks. I'm just working away on the work I'd like to get in. So tentatively hope to
be done this weekend.

On Feb 28, 2015, at 7:03 AM, Andreas Gudian <andreas.gudian@gmail.com> wrote:

> I'm done with my changes (documented in MNG-5776), and it seems to work -
> no at least the java process is started with the right parameters and no
> script variables leak out into the cmd console... ;-)
> 
> @Igor: thanks for checking up, I overlooked your second commit with the
> change of the VM-argument name.
> 
> 
> 2015-02-26 18:07 GMT+01:00 Jason van Zyl <jason@takari.io>:
> 
>> 
>> On Feb 26, 2015, at 3:49 AM, Andreas Gudian <andreas.gudian@gmail.com>
>> wrote:
>> 
>>> I can handle that, but not before the weekend.
>>> 
>>> Jason, does that conflict with your schedule for the release?
>>> 
>> 
>> No dire rush on my side and I have two feature branches to merge anyway so
>> take your time. Happy to have the help.
>> 
>>> Perhaps we just say that we drop the support for old Windows versions
>> with
>>> 3.3.0 and do the actual work that removes the support from the bat files
>> in
>>> the next minor release?
>>> 
>>> I would imagine that no one out there cares for Windows 98/ME anyway ;-).
>>> 
>>> 
>>> Am Donnerstag, 26. Februar 2015 schrieb Anders Hammar :
>>> 
>>>> On Thu, Feb 26, 2015 at 8:16 AM, Stephen Connolly <
>>>> stephen.alan.connolly@gmail.com <javascript:;>> wrote:
>>>> 
>>>>> On Thursday, February 26, 2015, Anders Hammar <anders@hammar.net
>>>> <javascript:;>> wrote:
>>>>> 
>>>>>>> 
>>>>>>> One thing we could do to make stuff easier around these .bat
scripts
>>>> is
>>>>>> to
>>>>>>> drop support for this 4NT shell and Windows versions that are
not
>>>> based
>>>>>> on
>>>>>>> NT (i.e. Windows 9x / ME).
>>>>>> 
>>>>>> 
>>>>>> Well, as Maven 3.2+ requires a minimum of JDK 1.6 there is no reason
>> to
>>>>>> support anything that JDK 1.6 doesn't run on.
>>>>> 
>>>>> 
>>>>> If we are calling this 3.3.0 we can just say we have dropped win 9x/Me
>>>>> support and the 4NT alternative command interpreter
>>>> 
>>>> 
>>>> Yes. We should probably clearly state what we support in the System
>>>> Requirements (both on-line and in distro).
>>>> And a JIRA ticket to go with this is good for the release notes.
>>>> 
>>>> /Anders
>>>> 
>>>> 
>>>> 
>>>>> 
>>>>> 
>>>>>> 
>>>>>> I can't find any info about Oracle JDK 1.6, but Oracle JDK 1.7
>>>> requires a
>>>>>> minimum of Windows Vista [1].
>>>>>> 
>>>>>> I couldn't find any info on openJDK's requirements.
>>>>>> 
>>>>>> IBM J9 JDK 6 seems to require a minimum of Windows XP SP3 [2].
>>>>>> 
>>>>>> [1] http://www.oracle.com/technetwork/java/javase/config-417990.html
>>>>>> [2]
>>>>>> 
>>>>>> 
>>>>> 
>>>> 
>> http://www-01.ibm.com/support/knowledgecenter/#!/SSYKE2_6.0.0/com.ibm.java.doc.60_26/vm626/GenericWrapper/hardwareandsoftwarerequirements.html
>>>>>> 
>>>>>> /Anders
>>>>>> 
>>>>>> 
>>>>>> 
>>>>>>> 
>>>>>>> 
>>>>>>> 
>>>>>>> 2015-02-25 19:38 GMT+01:00 Jason van Zyl <jason@takari.io
>>>> <javascript:;>
>>>>> <javascript:;>
>>>>>>> :
>>>>>>> 
>>>>>>>> Awesome, thanks!
>>>>>>>> 
>>>>>>>> On Feb 25, 2015, at 10:32 AM, Andreas Gudian <
>>>>> andreas.gudian@gmail.com <javascript:;>
>>>>>> <javascript:;>>
>>>>>>>> wrote:
>>>>>>>> 
>>>>>>>>> Hi guys,
>>>>>>>>> 
>>>>>>>>> I'm stuck with a windows box and I can give it a try...
>>>>>>>>> 
>>>>>>>>> .bat-scripting is not really a joy, but what's in the
patch
>>>> should
>>>>> be
>>>>>>>>> translatable.
>>>>>>>>> 
>>>>>>>>> Andreas
>>>>>>>>> 
>>>>>>>>> 2015-02-25 17:01 GMT+01:00 Igor Fedorenko <igor@ifedorenko.com
>>>> <javascript:;>
>>>>>> <javascript:;>>:
>>>>>>>>> 
>>>>>>>>>> You can see actual diff to mvn shell script in [1],
but the
>>>>> changes
>>>>>>> was
>>>>>>>>>> basically two-fold. First, find nearest parent directory
that
>>>>>> contains
>>>>>>>>>> .mvn/ subdirectory. This parent is considered "true"
>>>> multi-module
>>>>>>>>>> project root (MNG-1958). Second, if .mvn/java.config
file is
>>>>> present
>>>>>>>>>> immediately under the true multimodule project root,
use its
>>>>> content
>>>>>>> as
>>>>>>>>>> java invocation parameters, i.e. similar to $MAVEN_OPTS
>>>>> environment
>>>>>>>>>> variable.
>>>>>>>>>> 
>>>>>>>>>> I don't know enough about Windows scripting to make
similar
>>>> change
>>>>>> to
>>>>>>>>>> mvn.bat and mvnDebug.bat batch files.
>>>>>>>>>> 
>>>>>>>>>> [1]
>>>>> https://git-wip-us.apache.org/repos/asf?p=maven.git;a=commit;h=
>>>>>>>>>> 8ed9a1caa8890773b45c6c408a4e40acf4f4b0fd
>>>>>>>>>> 
>>>>>>>>>> --
>>>>>>>>>> Regards,
>>>>>>>>>> Igor
>>>>>>>>>> 
>>>>>>>>>> 
>>>>>>>>>> On 2015-02-25 9:56, Robert Patrick wrote:
>>>>>>>>>> 
>>>>>>>>>>> What exactly is the problem that Igor ran into
that limits his
>>>>>>> solution
>>>>>>>>>>> to Unix-only?  Knowing this would help people
determine what
>>>> the
>>>>>>> level
>>>>>>>> of
>>>>>>>>>>> effort needed to solve the problem.
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> --
>>>>>>>>>>> Robert Patrick <robert.patrick@oracle.com
<javascript:;>
>>>> <javascript:;>>
>>>>>>>>>>> VP, Oracle Corporation
>>>>>>>>>>> 7460 Warren Pkwy, Ste. 300      Office: +1.972.963.2872
>>>>>>>>>>> Frisco, TX 75034, USA           Mobile: +1.469.556.9450
>>>>>>>>>>> 
>>>>>>>>>>> Professional Oracle WebLogic Server
>>>>>>>>>>> by Robert Patrick, Gregory Nyberg, and Philip
Aston
>>>>>>>>>>> with Josh Bregman and Paul Done
>>>>>>>>>>> Book Home Page: http://www.wrox.com/
>>>>>>>>>>> Kindle Version: http://www.amazon.com/
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> -----Original Message-----
>>>>>>>>>>> From: Jason van Zyl [mailto:jason@takari.io <javascript:;>
>>>> <javascript:;>]
>>>>>>>>>>> Sent: Wednesday, February 25, 2015 7:40 AM
>>>>>>>>>>> To: Maven Developers List
>>>>>>>>>>> Subject: Re: Maven 3.2.6
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> On Feb 24, 2015, at 11:31 PM, Arnaud Héritier
<
>>>>> aheritier@gmail.com <javascript:;>
>>>>>> <javascript:;>>
>>>>>>>>>>> wrote:
>>>>>>>>>>> 
>>>>>>>>>>> I had a quick look at the changeling and I'm
+1 for a 3.3.0
>>>> with
>>>>>>>>>>>> improvements like the toolchain integration
and few others I'm
>>>>> far
>>>>>>>>>>>> from the project and won't veto anything
as I have no time for
>>>>> it
>>>>>>> but
>>>>>>>>>>>> I don't understand why
>>>> http://jira.codehaus.org/browse/MNG-5767
>>>>>> was
>>>>>>>>>>>> integrated without a windows support ? For
me it is everything
>>>>> or
>>>>>>>>>>>> nothing.
>>>>>>>>>>>> Noone could help Igor on this ?
>>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> It would be great if someone would help, but
it is still a step
>>>>>>>> forward.
>>>>>>>>>>> For projects that require this and document specific
>>>> requirements
>>>>>> it
>>>>>>>> will
>>>>>>>>>>> just work for non-Windows users. Say the project
needs 8gb to
>>>> run
>>>>>>>>>>> correctly: in most cases no one reads the documentation
they
>>>> run
>>>>>> the
>>>>>>>> build
>>>>>>>>>>> and it fails. Then they go read something and
figure it out and
>>>>> it
>>>>>>>> works.
>>>>>>>>>>> We've at least made it work for some people.
If there isn't a
>>>>>> single
>>>>>>>> Maven
>>>>>>>>>>> committer who uses Windows who can add the same
capabilities or
>>>>> we
>>>>>>>> can't
>>>>>>>>>>> find a contributor I don't think it should stop
the feature for
>>>>>> going
>>>>>>>> in
>>>>>>>>>>> for the people it can benefit.
>>>>>>>>>>> 
>>>>>>>>>>> Igor and I don't use Windows regularly, don't
know Windows,
>>>> don't
>>>>>>> want
>>>>>>>> to
>>>>>>>>>>> know Windows and none of our customers use Windows.
>>>>>>>>>>> 
>>>>>>>>>>> It's overall a net improvement. For me it's a
about gradual
>>>>>>>> improvement.
>>>>>>>>>>> But I've asked on Twitter if there are any Windows
users that
>>>> can
>>>>>>> help.
>>>>>>>>>>> 
>>>>>>>>>>> Many months/years ago the integration of colors
in logs output
>>>>> was
>>>>>>>>>>>> rejected in a part because we wasn't confident
in the windows
>>>>>>> support
>>>>>>>> ...
>>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> I don't think that was the issue. The issue was
us not being
>>>> able
>>>>>> the
>>>>>>>>>>> decide on an underlying logging framework. I've
seen JANSI
>>>>> working
>>>>>>>> fine on
>>>>>>>>>>> Windows for years.
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>>> My 2 cents.
>>>>>>>>>>>> 
>>>>>>>>>>>> On Wed, Feb 25, 2015 at 1:29 AM, Mark Derricutt
<
>>>>> mark@talios.com <javascript:;>
>>>>>> <javascript:;>>
>>>>>>>> wrote:
>>>>>>>>>>>> 
>>>>>>>>>>>> On 25 Feb 2015, at 4:06, Karl Heinz Marbaise
wrote:
>>>>>>>>>>>>> 
>>>>>>>>>>>>> based on the list of changes i would
suggest to make a 3.3.0
>>>>>>> instead
>>>>>>>>>>>>>> of
>>>>>>>>>>>>>> 
>>>>>>>>>>>>> 3.2.6....to make clear something is introduced....
>>>>>>>>>>>>> 
>>>>>>>>>>>>> +1 on 3.3.0 here. Bring on the changes!
>>>>>>>>>>>>> 
>>>>>>>>>>>>> Mark
>>>>>>>>>>>>> 
>>>>>>>>>>>>> --
>>>>>>>>>>>>> Mark Derricutt
>>>>>>>>>>>>> http://www.theoryinpractice.net
>>>>>>>>>>>>> http://www.chaliceofblood.net
>>>>>>>>>>>>> http://plus.google.com/+MarkDerricutt
>>>>>>>>>>>>> http://twitter.com/talios
>>>>>>>>>>>>> http://facebook.com/mderricutt
>>>>>>>>>>>>> 
>>>>>>>>>>>>> 
>>>>>>>>>>>> 
>>>>>>>>>>>> 
>>>>>>>>>>>> --
>>>>>>>>>>>> -----
>>>>>>>>>>>> Arnaud Héritier
>>>>>>>>>>>> http://aheritier.net
>>>>>>>>>>>> Mail/GTalk: aheritier AT gmail DOT com Twitter/Skype
:
>>>> aheritier
>>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> Thanks,
>>>>>>>>>>> 
>>>>>>>>>>> Jason
>>>>>>>>>>> 
>>>>>>>>>>> ----------------------------------------------------------
>>>>>>>>>>> Jason van Zyl
>>>>>>>>>>> Founder, Takari and Apache Maven
>>>>>>>>>>> http://twitter.com/jvanzyl
>>>>>>>>>>> http://twitter.com/takari_io
>>>>>>>>>>> ---------------------------------------------------------
>>>>>>>>>>> 
>>>>>>>>>>> People develop abstractions by generalizing from
concrete
>>>>> examples.
>>>>>>>>>>> Every attempt to determine the correct abstraction
on paper
>>>>> without
>>>>>>>>>>> actually developing a running system is doomed
to failure. No
>>>> one
>>>>>> is
>>>>>>>> that
>>>>>>>>>>> smart. A framework is a resuable design, so you
develop it by
>>>>>> looking
>>>>>>>> at
>>>>>>>>>>> the things it is supposed to be a design of.
The more examples
>>>>> you
>>>>>>>> look at,
>>>>>>>>>>> the more general your framework will be.
>>>>>>>>>>> 
>>>>>>>>>>> -- Ralph Johnson & Don Roberts, Patterns
for Evolving
>>>>> Frameworks
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>> ---------------------------------------------------------------------
>>>>>>>>>>> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
>>>> <javascript:;>
>>>>>> <javascript:;> For
>>>>>>>> additional
>>>>>>>>>>> commands, e-mail: dev-help@maven.apache.org <javascript:;>
>>>> <javascript:;>
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>> ---------------------------------------------------------------------
>>>>>>>>>>> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
>>>> <javascript:;>
>>>>>> <javascript:;>
>>>>>>>>>>> For additional commands, e-mail: dev-help@maven.apache.org
>>>> <javascript:;>
>>>>>> <javascript:;>
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>> 
>>>>>> ---------------------------------------------------------------------
>>>>>>>>>> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
>>>> <javascript:;>
>>>>>> <javascript:;>
>>>>>>>>>> For additional commands, e-mail: dev-help@maven.apache.org
>>>> <javascript:;>
>>>>>> <javascript:;>
>>>>>>>>>> 
>>>>>>>>>> 
>>>>>>>> 
>>>>>>>> Thanks,
>>>>>>>> 
>>>>>>>> Jason
>>>>>>>> 
>>>>>>>> ----------------------------------------------------------
>>>>>>>> Jason van Zyl
>>>>>>>> Founder, Takari and Apache Maven
>>>>>>>> http://twitter.com/jvanzyl
>>>>>>>> http://twitter.com/takari_io
>>>>>>>> ---------------------------------------------------------
>>>>>>>> 
>>>>>>>> Lastly, "Impossible." The lamest of the lame excuses! Difficult
>>>>> maybe,
>>>>>> or
>>>>>>>> impractical, or too expensive, but rarely is anything impossible.
>>>>>>>> 
>>>>>>>> -- Yvon Chouinard, Let my People Go Surfing
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>> ---------------------------------------------------------------------
>>>>>>>> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
>>>> <javascript:;>
>>>>>> <javascript:;>
>>>>>>>> For additional commands, e-mail: dev-help@maven.apache.org
>>>> <javascript:;>
>>>>>> <javascript:;>
>>>>>>>> 
>>>>>>>> 
>>>>>>> 
>>>>>> 
>>>>> 
>>>>> 
>>>>> --
>>>>> Sent from my phone
>>>>> 
>>>> 
>> 
>> Thanks,
>> 
>> Jason
>> 
>> ----------------------------------------------------------
>> Jason van Zyl
>> Founder, Takari and Apache Maven
>> http://twitter.com/jvanzyl
>> http://twitter.com/takari_io
>> ---------------------------------------------------------
>> 
>> the course of true love never did run smooth ...
>> 
>> -- Shakespeare
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
>> For additional commands, e-mail: dev-help@maven.apache.org
>> 
>> 

Thanks,

Jason

----------------------------------------------------------
Jason van Zyl
Founder, Takari and Apache Maven
http://twitter.com/jvanzyl
http://twitter.com/takari_io
---------------------------------------------------------

We know what we are, but know not what we may be.

  -- Shakespeare













---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message