maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henning Schmiedehausen <henn...@schmiedehausen.org>
Subject Re: Releasing the Checkstyle Plugin
Date Thu, 22 Jan 2015 17:46:24 GMT
On Wed, Jan 21, 2015 at 11:49 PM, Dennis Lundberg <dennisl@apache.org> wrote:
> On Thu, Jan 22, 2015 at 5:29 AM, Hervé BOUTEMY <herve.boutemy@free.fr> wrote:
>> Le mercredi 21 janvier 2015 14:44:27 Dennis Lundberg a écrit :
>>> There is some piece of code in Checkstyle 5.9 that uses Java 6+
>>> classes/methods. I don't remember where, but it isn't covered by our
>>> integration tests.
>> since our ITs use the 3 integrated rulesets, I suppose this is in a rule that
>> isn't used by these rulesets
>> Notice: the animalsniffer check you added doesn't check dependency jars full
>> content?
>
> No, and I don't think we can get that from our end. We had newer Java
> versions leaking into Apache Rat, and I solved those by adding a
> combination of animal-sniffer and enforcer plugin. But I don't think
> that can check the sources of the dependencies. It's a mystery to me
> how they managed to build Checkstyle 5.9 at all. When I check out the
> 5.9 tag from git and try to build it using Java 1.5 I get these
> errors:

Java 6 or 7 compiler with java6 rt.jar and -source 1.5 -target 1.5

Unfortunately the result does not actually work on JDK5. :-/

-h

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message