maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benson Margulies <bimargul...@gmail.com>
Subject Re: [DISCUSS] Move everything to 1.6, take 2 (was: Re: I can't make a release ...)
Date Tue, 30 Dec 2014 23:42:13 GMT
On Tue, Dec 30, 2014 at 6:36 PM, Hervé BOUTEMY <herve.boutemy@free.fr> wrote:
> personnally, I use invoker: no compatibility problems

I try to make unit tests when I can make unit tests. it's a religion,
or a disease. I agree that falling back to the invoker is the
fallback.

>
> Regards,
>
> Hervé
>
> Le mardi 30 décembre 2014 17:45:36 Benson Margulies a écrit :
>> In my experience, there are significant API issues between 3.0 and
>> 3.1. My particular obsession is with the plugin testing harness.
>>
>> I've had several experiences of the following forn:
>>
>> 1: go to fix a problem in a plugin.
>> 2: try to create an appropriately focussed test
>> 3: try to set up the testing harness
>> 4: get told that all no one understands the version of the testing
>> harness that corresponds to the version of Maven targetted by the
>> plugin, and, in fact, that maintained branch only works with 3.1+.
>>
>> I'd be very happy to read that I've misunderstood and that a floor of
>> '3.0' is enough to get to a working, documented, set of testing tools.
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
>> For additional commands, e-mail: dev-help@maven.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message