maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Heinz Marbaise <>
Subject Re: Next Maven prerequisite for Maven Plugins
Date Sun, 12 Oct 2014 13:25:35 GMT
Hi Robert,

from my point of view minimum to 3.0.5 ...nothing below...afterwards 
3.1.1.....and then 3.2.1...the latest releases from the appropriate 
release lines 3.0.X, 3.1.X, 3.2.X,....

I wouldn't go to 3.1.0 at the moment cause that could be 
confusing....from user point of view...than there is a gap...


 From my side...

Kind regards
Karl Heinz Marbaise

 > Hi,
> Right now we change the Maven prerequisite to 2.2.1 and I noticed some
> new issues which already want to move it forward to 3.0.4. I wonder why
> to move to this version.
> Most (API-)changes have been introduced with the 3.0 alpha and beta
> releases. I don't think that the other 3.0.x releases provide that much
> more changes.
> So I would say that changing the required Maven version would be 3.0.
> *If* we want to force users not to use 3.0.4 due to the CVE-2013-0253,
> we should say that 3.0.5 is the next required version of Maven.
> And I could go one step further: if we want to get rid of the
> compatibility overhead for Aether (Sonatype versus Eclipse) we should
> change it to 3.1.0
> So I'd prefer to move forward to 3.0, maybe even to 3.1.0, but not to
> 3.0.4 unless there are better reasons then I mentioned above.
> Any other opinions?
> thanks,
> Robert

Kind regards
Karl Heinz Marbaise

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message