maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benson Margulies <bimargul...@gmail.com>
Subject Re: Building the release plugin: fails every time.
Date Sat, 13 Sep 2014 16:45:59 GMT
M2_HOME has to be set. I've added this to the site doc.

On Sat, Sep 13, 2014 at 10:33 AM, Benson Margulies <bimargulies@gmail.com>
wrote:

> I am completely failing to remember what I might have done differently.
>
> On Sat, Sep 13, 2014 at 10:11 AM, Robert Scholte <rfscholte@apache.org>
> wrote:
>
>> I don't recall that something has changed here since you released 2.5...
>>
>> Op Sat, 13 Sep 2014 16:03:18 +0200 schreef Benson Margulies <
>> bimargulies@gmail.com>:
>>
>>
>>  I see it at command-line, with just 'mvn install'.
>>>
>>>
>>> On Sat, Sep 13, 2014 at 10:02 AM, Robert Scholte <rfscholte@apache.org>
>>> wrote:
>>>
>>>  IIRC I'm getting this error when executed within the IDE, commandline
>>>> works fine.
>>>>
>>>> Robert
>>>>
>>>> Op Sat, 13 Sep 2014 13:49:52 +0200 schreef Benson Margulies <
>>>> bimargulies@gmail.com>:
>>>>
>>>>
>>>>  On Linux, where i keep a very vanilla environment for this sort of
>>>> thing,
>>>>
>>>>> running mvn test on the maven-release-plugin (using maven 3.0.5)
>>>>> yields:
>>>>>
>>>>> Tests in error:
>>>>>   InvokerMavenExecutorTest.testEncryptSettings:132 ยป IllegalState
>>>>> Maven
>>>>> applicat...
>>>>>
>>>>> Help?
>>>>>
>>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
>>>> For additional commands, e-mail: dev-help@maven.apache.org
>>>>
>>>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
>> For additional commands, e-mail: dev-help@maven.apache.org
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message