maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: Defective Nov 5 upload to Maven central of Eclipse artifacts broke our build
Date Wed, 13 Nov 2013 16:13:01 GMT

On 11/13/2013 10:21 AM, Arnaud Héritier wrote:
> I had a similar issue but I solved it by removing some JBoss repositories
> Are you sure that the problem is in central ?
Not sure.  It's found by this website:
http://search.maven.org/remotecontent?filepath=org/eclipse/core/runtime/3.9.0-v20130326-1255/runtime-3.9.0-v20130326-1255.pom

and I see it's located here:

http://central.maven.org/maven2/org/eclipse/core/runtime/3.9.0-v20130326-1255/

which seems to be the central maven repository?

-Marshall

>
>
> On Wed, Nov 13, 2013 at 3:57 PM, Marshall Schor <msa@schor.com> wrote:
>
>> Hi,
>>
>> First, apologies if this is not the right mailing list for Maven Central
>> issues...
>>
>> On Nov 5, someone uploaded to Maven Central some new versions of Eclipse
>> artifacts.
>>
>> In particular, they uploaded:
>>
>> org.eclipse.core : runtime : 3.9.0-v20130326-1255  and
>> org.eclipse.equinox: app : 1.3.100-v20130327-1442
>>
>> The POM for this runtime artifact has this (faulty) dependency on the "app"
>> artifact:
>>
>> |    ||<||dependency||>|
>> |      ||<||groupId||>org.eclipse.equinox <http://search.maven.org/#
>>> </||groupId||>|
>> |      ||<||artifactId||>app <http://search.maven.org/#></||artifactId||>|
>> |      ||<||version||>1.0.0</||version||>|
>> |      ||<||optional||>false</||optional||>|
>> |    ||</||dependency||>|
>>
>> Specifying the dependency as "1.0.0" causes Maven 3.0.x to fail to locate
>> this
>> artifact.  See
>> https://cwiki.apache.org/confluence/display/MAVENOLD/Versioning
>>
>> This has broken our previous source release's ability to build from source.
>> We'll fix this going forward, for our build, but
>>
>> For reference, prior to this change, the previous
>> "org.eclipse.core:runtime" had
>> this dependency specified with a range notation, as:
>>
>> |    ||<||dependency||>|
>> |      ||<||groupId||>org.eclipse.equinox <http://search.maven.org/#
>>> </||groupId||>|
>> |      ||<||artifactId||>app <http://search.maven.org/#></||artifactId||>|
>> |      ||<||version||>[1.0.0,2.0.0)</||version||>|
>> |    ||</||dependency||>|
>>
>> This has broken our previous source releases' ability to build from source.
>> We'll fix this for our builds, going forward, but it would be nice if the
>> maven
>> central administrators would contact the uploader and have them correct
>> this
>> dependency specification (as well as other errors that might have crept
>> in), so
>> our previously releases could continue to build.
>>
>> -Marshall Schor
>>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message