maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Barrie Treloar <baerr...@gmail.com>
Subject Re: Wagon & PRoxy auth ??
Date Tue, 03 Sep 2013 06:17:09 GMT
On 3 September 2013 15:12, Kristian Rosenvold
<kristian.rosenvold@gmail.com> wrote:
> While looking at the access denied problem for wagon, I ran into this code
> line:
>
> https://github.com/apache/maven-wagon/blob/master/wagon-providers/wagon-http/src/main/java/org/apache/maven/wagon/providers/http/AbstractHttpClientWagon.java#L740
>
> The call uses a deprecated version of "authenticated" that regenerates the
> BasicHttpContext every time.
> The new (not deprecated) version would seem to be just
>
>                 Header bs = new BasicScheme().authenticate( creds,
> httpMethod, localContext );
>
> (Where we add the existing localContext variable)
>
> I am a bit puzzled that the current code works with authenticated proxies
> at all, but this code is
> certainly not my domain. Is this a bug ?

I've always had problems being behind an NTLM proxy.
It doesn't bother me in normal use because we use a repository manager anyway.
Where I get bitten is in running integration tests, as there is often
a settings.xml file with stuff in it for that particular Maven IT
which fails because of the NTLM proxy.

So since I mostly work around the problem I have not verified whether
its been fixed properly.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message