maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Benedict <pbened...@apache.org>
Subject Re: [VOTE] All new (non-patch) releases of Maven Core after 30th Sep 2013 to require Java 6+
Date Tue, 23 Jul 2013 15:36:32 GMT
+1 non binding.


On Tue, Jul 23, 2013 at 10:33 AM, Jeff Jensen <
jeffjensen@upstairstechnology.com> wrote:

> +1 (non-binding)
>
> On Tue, Jul 23, 2013 at 8:59 AM, Stephen Connolly
> <stephen.alan.connolly@gmail.com> wrote:
> > This vote is to cover the minimum required version of Java for Maven
> Core.
> >
> > Maven Plugins produced by the Apache Maven Project that are flagged as
> > compatible with older versions of Maven Core as their baseline will still
> > require to stick to the minimum Java requirements of that Maven Core
> > version. In other words, if for example maven-compiler-plugin advertises
> > compatibility with Maven Core 2.0.11+ then that will still need to be
> > compiled targeting Java 1.4 and only using dependencies that are aligned
> > with that runtime requirement.
> >
> > Additionally patch releases to existing releases of Maven Core will not
> be
> > subject to this requirement.
> >
> > For example [example]*if* this vote passes and *if* on Sep 29th we
> release
> > Maven 3.2.0 and *if* on Oct 2nd we release Maven 2.0.12, Maven 2.2.2,
> Maven
> > 3.0.6, Maven 3.1.1, Maven 3.2.1 and Maven 3.3.0 (due to say some security
> > issue that affected all versions of Maven) then only Maven 3.3.0 would be
> > require Java 6 as a minimum runtime requirement, the 2.0.12 release would
> > still require Java 1.4 and the 2.2.2, 3.0.6, 3.1.1 and 3.2.1 versions
> would
> > all still require Java 1.5.[/example]
> >
> > This is not a requirement that 3rd party plugins need use Java 6 as a
> > minimum. Third party plugins are free to require any Java version >= the
> > corresponding Maven minimum requirement, though obviously from a users
> > perspective it is best if plugins try to adhere to our contracts for
> > corresponding versions of Maven Core.
> >
> > Justification for the cut-off date:
> >
> > * Oracle has gone end of life on Java 6 Feb 2013 (note that there is
> still
> > extended and sustaining support for existing Oracle customers using Java
> 5)
> > * IBM will go end of life for z/OS on 30th Sep 2013 (other platforms are
> > still with support, but there are other Java vendors for other platforms)
> > * Apple no longer supports any hardware that does not have at least an
> > Apple Java 6 version available.
> > * Red Hat is providing support for OpenJDK 6
> > * HP-UX, OpenVMS, and Tru64 all have a Java 6 implementation available.
> >
> > As I see it, that essentially ensures that for the vast majority of
> > platforms there is a very strong likelihood of a Java 6 compatible
> version
> > of Java available for that platform. Toolchains support or forking of the
> > compiler and surefire can provide support for users who still need to
> build
> > with older versions of Java (e.g., as was the case for Java 1.4.2 with
> > Maven 2.2.1). Additionally users who are forced to use a java version
> older
> > than Java 6 also are likely unable to upgrade their version of Maven, so
> > this change will not affect them
> >
> > This vote is open for 72 hours. A minimum of three +1 binding votes (i.e.
> > from the PMC) and the majority of votes cast from committers will be
> > required to pass this vote.
> >
> > +1000: Yes, and when can we have the vote to go for Java 7 as a minimum?
> > (This option is equivalent to +1 but provides people the ability to
> > indicate an additional preference while not contributing to the
> inevitible
> > noise)
> > +1: Yes
> > 0: No opinion
> > -1: No
> >
> > -Stephen
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
>
>


-- 
Cheers,
Paul

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message