maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason van Zyl <ja...@tesla.io>
Subject Plugin testing
Date Tue, 23 Jul 2013 11:54:30 GMT
Hi,

I updated the plugin-testing tools to work with Maven 3.1.0 to help Manfred get the Android
Maven Plugin's test harness working with 3.1.0. A couple things:

1. There is an @Override for a method implemented for an interface which you can only start
doing in Java 1.6 and the compiler was defaulting to 1.5 because no target/source were being
specific. So I'm not sure if this is a mistake but I set the source/target to 1.6 so that
I didn't have to remove the annotation. 

2. I should probably bump the version to 3.0.0-SNAPSHOT instead of the 2.2-SNAPSHOT, any thoughts
here?

3. And now that I'm working on this I'd like to get it out of Subversion and push it over
to Git, any objections? I'd prefer to do that before making a branch for the older version.

Thanks,

Jason

----------------------------------------------------------
Jason van Zyl
Founder,  Apache Maven
http://twitter.com/jvanzyl
---------------------------------------------------------

Script timed out







Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message