maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Heinz Marbaise <khmarba...@gmx.de>
Subject Maven-Plugin: Maven 3.1 related Question
Date Wed, 03 Jul 2013 20:44:40 GMT
Hi to the developers,

currently I'm trying to build my plugin with the announced Maven 3.1 
release...which produces the following problem in my integration tests:

Caused by: org.apache.maven.plugin.PluginExecutionException: Execution 
default of goal 
com.soebes.maven.plugins:iterator-maven-plugin:0.1.1-SNAPSHOT:executor 
failed: An API incompatibility was encountered while executing 
com.soebes.maven.plugins:iterator-maven-plugin:0.1.1-SNAPSHOT:executor: 
java.lang.NoSuchMethodError: 
org.apache.maven.execution.MavenSession.getRepositorySession()Lorg/sonatype/aether/RepositorySystemSession;


Is this related the follwing information: 
https://cwiki.apache.org/confluence/display/MAVEN/AetherClassNotFound

If so can someone give me hint what would solve the problem ?
I've searched through the sources/JIRA tickets etc. of the different 
plugins but only found a dependency like this:

     <dependency>
       <groupId>org.eclipse.aether</groupId>
       <artifactId>aether-util</artifactId>
       <version>0.9.0.M2</version>
     </dependency>

but that seemed to be not the cause...or do i mistaken or oversight 
something ?


Many thanks in advance.
Kind regards
Karl-Heinz Marbaise
-- 
SoftwareEntwicklung Beratung Schulung    Tel.: +49 (0) 2405 / 415 893
Dipl.Ing.(FH) Karl-Heinz Marbaise        ICQ#: 135949029
Hauptstrasse 177                         USt.IdNr: DE191347579
52146 W├╝rselen                           http://www.soebes.de

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message