maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kristian Rosenvold <kristian.rosenv...@gmail.com>
Subject Re: [VOTE] Release Maven Surefire Plugin version 2.15
Date Sun, 09 Jun 2013 19:57:39 GMT
2 years ago, a bump to 1.5 might have been worth a 3.0. Now it's
hardly worth a yawn. That's my 0.02 NOK.

I've been cooking on a "3.0" scope including:

- Finalization of provider API's including several minor changes.
- Adding extension points and the possibility to pick these up from
test-classpath.
- Changing some of the not-too good default values (changing  default
includes to * comes to mind)
- Further simplify the classloader structure, become stealthier with
modern JVM options.
  (The first steps have been taken in 1.15, which I should make a jira
for right now....)

Kristian



2013/6/9 Andreas Gudian <andreas.gudian@gmail.com>:
> Am Sonntag, 9. Juni 2013 schrieb Stephen Connolly :
>
>> On Friday, 7 June 2013, Andreas Gudian wrote:
>>
>> >
>> > We solved 16 issues:
>> >
>> >
>> https://jira.codehaus.org/secure/ReleaseNote.jspa?projectId=10541&version=19174
>> >
>> > This is the first release that does not support JVM versions prior 1.5 to
>> > be forked.
>>
>>
>> I thought the plan was to bump the major version for this change?
>
>
> Oh, you're right, that's what Kristian wrote initially. There is still a
> lot to do for what we have in mind for a 3.0 release (e.g. the extension
> points). That's why I didn't have that in mind.
> @Kristian, what's your opinion on that?

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message