maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Goodwin" <sgood...@cfl.rr.com>
Subject Maven assembly plugin throwing error
Date Fri, 21 Jun 2013 03:00:41 GMT
Hi,

I am simply trying to create a .zip from some folders in an svn project.  When I try to run
this a maven build I get the following error:

ERROR] BUILD ERROR
    [INFO] ------------------------------------------------------------------------
    [INFO] Compiler errors:
    error no sources specified
    abort AspectJ Compiler 1.6.11

        Usage: <options> <source file | @argfile>..

    AspectJ-specific options:
        -inpath <list>      use classes in dirs and jars/zips in <list> as source
                            (<list> uses platform-specific path delimiter)
        -injars <jarList>   use classes in <jarList> zip files as source
                            (<jarList> uses classpath delimiter)
...

Here is my descriptor xml file contents...
    <assembly xmlns="http://maven.apache.org/plugins/maven-assembly-plugin/assembly/1.1.0"

      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:schemaLocation="http://maven.apache.org/plugins/maven-assembly-plugin     

     /assembly      /1.1.0 http://maven.apache.org/xsd/assembly-1.1.0.xsd">
  <id>batch</id>
  <formats>
    <format>zip</format>
  </formats>
  <fileSets>
    <fileSet>
      <directory>${project.basedir}/src/main/scripts</directory>
      <outputDirectory>/scripts/</outputDirectory>
      <includes>
        <include>*</include>
      </includes>
    </fileSet>  
 <fileSet>
      <directory>${project.basedir}/src/main/resources/lib</directory>
      <outputDirectory>/lib/</outputDirectory>
      <includes>
        <include>*</include>
      </includes>
    </fileSet>
  </fileSets>
    </assembly>

... and here is the build section of my POM  ...

   <build>
  <plugins>
   <plugin>
    <artifactId>maven-assembly-plugin</artifactId>
    <configuration>
     <descriptors>
      <descriptor>src/main/assembly  
     /nge-batch.xml</descriptor>
     </descriptors>
      </configuration>
    <executions>
      <execution>
      <id>make-assembly</id>
       <phase>package</phase>
      <goals>
        <goal>single</goal>
      </goals>
      </execution>
    </executions>
     </plugin>
  </plugins>
 </build>

I don't have any dependencies definded in my POM.  Using maven 2.2.1 and here is my command:

-B clean deploy (inside a GUI buildtool)

Do you have any ideas on why I am getting the "no sources found" aspectJ error message and
what to do about it?

Thank you.

- Spuds23
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message