maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Heinz Marbaise <>
Subject Re: [VOTE] Release Maven Surefire Plugin version 2.15
Date Fri, 07 Jun 2013 17:41:40 GMT

first a:
+1 (non binding)

from me..

Apart from that I've stumbled over serval things which might be fixed in 
the future:

     Property name: failIfNoTests

but failIfNoSpecifiedTests where the property is name: 

So i would suggest to name failIfNoTests property accordingly like 

debugForkedProcess where the property name is: maven.failsafe.debug
so the question is if the name of the property for enableAssertions 
should be named accordingly like maven.failsafe.enableAssertions ?

For excludeGroups it should be done the same way like 
maven.failsafe.excludeGroups or it.excludeGroups ?
The groups for TestNG should be named accordingly like it.groups ?

Furthermore having a forkCount where it's property name is forkCount 
where i would suggest having something like: it.forkCount apart from 
that the documentation for forkCount talks about ${surefire.forkCount} 
should be changed into ${failsafe.forkCount} ?

This is also the case for jvm, objectFactory, parallel, 
perCoreThreadCount, properties ...

Thanks for a new release ...

Kind regards
Karl-Heinz Marbaise
SoftwareEntwicklung Beratung Schulung    Tel.: +49 (0) 2405 / 415 893
Dipl.Ing.(FH) Karl-Heinz Marbaise        ICQ#: 135949029
Hauptstrasse 177                         USt.IdNr: DE191347579
52146 W├╝rselen                 

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message