maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Heinz Marbaise <khmarba...@gmx.de>
Subject Re: [VOTE] Apache 3.1.0-alpha-1
Date Sat, 27 Apr 2013 17:52:31 GMT
-1 (non binding)

I've found an issue with an integration of my plugin developments which 
works with Maven 3.0.X without any problem but with Maven 3.1-alpha-1 it 
fails.
I've created a gist (https://gist.github.com/khmarbaise/5473941) which 
shows the whole debug output following only an excerpt:

[DEBUG]   (f) project = MavenProject: 
org.codehaus.mojo:build-metadata-maven-plugin-report-it:1.0-SNAPSHOT @ 
/Users/km/ws-git/build-metadata-maven-plugin/target/it/metadatareport/pom.xml
[DEBUG] -- end configuration --
[DEBUG] executing Site Mojo
[WARNING] Error injecting: 
org.apache.maven.reporting.exec.DefaultMavenReportExecutor
java.lang.NoClassDefFoundError: org/sonatype/aether/graph/DependencyFilter
   at java.lang.Class.getDeclaredConstructors0(Native Method)
	at java.lang.Class.privateGetDeclaredConstructors(Class.java:2389)
	at java.lang.Class.getDeclaredConstructors(Class.java:1836)

Is that a known issue ?

Kind regards
Karl-Heinz Marbaise
-- 
SoftwareEntwicklung Beratung Schulung    Tel.: +49 (0) 2405 / 415 893
Dipl.Ing.(FH) Karl-Heinz Marbaise        ICQ#: 135949029
Hauptstrasse 177                         USt.IdNr: DE191347579
52146 W├╝rselen                           http://www.soebes.de

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message