maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kristian Rosenvold <kristian.rosenv...@gmail.com>
Subject Terminate java 1.3 and 1.4 support in surefire
Date Tue, 26 Mar 2013 12:32:28 GMT
I think it's time we remove 1.3 and 1.4 support from surefire and make
1.5 a required minimum all across the board.

The plugin has required 1.5 for quite some time now, but we have been
able to fork down to 1.3 if necessary.

The main reason for doing this upgrade is that it is /hard/ to support
and makes surefire more complex than necessary.
The rest of the maven toolstack has also move to 1.5 across the board.

This is not a vote as such; raise your voice if you think we should
keep 1.3/1.4 support around ;)

Unless someone has concerns we'll bump the next major release to 3.0
and move on.

Kristian

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message