maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte" <rfscho...@apache.org>
Subject [ANN] Maven Invoker Plugin 1.8 Released
Date Tue, 27 Nov 2012 17:48:36 GMT
The Apache Maven team is pleased to announce the release of the Maven
Invoker Plugin, version 1.8

The Invoker Plugin is used to run a set of Maven projects. The plugin can
determine whether each project execution is successful, and optionally can
verify the output generated from a given project execution.

This plugin is in particular handy to perform integration tests for other
Maven plugins. The Invoker Plugin can be employed to run a set of test
projects that have been designed to assert certain features of the plugin
under test.

http://maven.apache.org/plugins/maven-invoker-plugin/

You should specify the version in your project's plugin configuration:

<plugin>
     <groupId>org.apache.maven.plugins</groupId>
     <artifactId>maven-invoker-plugin</artifactId>
     <version>1.8</version>
</plugin>

Release Notes - Maven 2.x Invoker Plugin - Version 1.8

** Bug
       * [MINVOKER-106] - invoker.java.version is always evaluated against
current JVM instead of JVM running the builds
       * [MINVOKER-115] - install goal doesn't install required plugins from
the reactor build to the local repo
       * [MINVOKER-118] - Specifying an unset property in <properties>  
causes
a NullPointerException
       * [MINVOKER-126] - mavenHome in relationship with
invoker.maven.version rule
       * [MINVOKER-133] - Using mergeUserSettings configuration parameter
with multiple executions causes IllegalStateException
       * [MINVOKER-137] - Maven 2.2.1 NullPointerException with
mergeUserSettings parameter
       * [MINVOKER-142] - Make it possible to specify debug-mode in
invoker.properties

** Improvement
       * [MINVOKER-124] - Reporting the reason for skipping an integration
tests
       * [MINVOKER-138] - Add groovy-all dependency instead of groovy by
default
       * [MINVOKER-139] - use last plexus-utils 3.0.7 which is faster on
copying files.
       * [MINVOKER-140] - Support exclusion with invokerTest
       * [MINVOKER-143] - Update Maven Invoker to 2.1.1

** New Feature
       * [MINVOKER-146] - Support modifying maven executable

** Task
       * [MINVOKER-144] - Change Prerequisite version of Maven to 2.2.1


Enjoy,

-The Apache Maven team

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message