maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benson Margulies <bimargul...@gmail.com>
Subject Re: maven-changes-plugin: rest
Date Thu, 22 Nov 2012 02:15:57 GMT
On Wed, Nov 21, 2012 at 8:59 PM, Brett Porter <brett@apache.org> wrote:
>
> On 22/11/2012, at 11:30 AM, Benson Margulies <bimargulies@gmail.com> wrote:
>
>> Coast is clear.
>>
>> I have two proposals to offer:
>>
>> 1) Set version to 3.0, remove parameter Q support, thus reducing the complexity.
>>
>> 2) Set version to 3.0, remove all RSS support, thus requiring JIRA 4.2.
>>
>> In either case, anyone who wants to use an older JIRA can use 2.8.
>
> Atlassian doesn't support anything < 4.2 (https://confluence.atlassian.com/display/Support/Atlassian+Support+End+of+Life+Policy),
and in practice I think they're even more aggressive. It's probably not a problem moving up
to it if it is justified.
>
> That said, the REST API doesn't need to be enabled, so some people may want RSS anyway
- I guess it depends whether that part is broken or causing extra work.

That would point toward option 1. We get rid of the small bag of
trouble from the pre-4 query URL syntax. Note that 5.1.x users with
REST disabled are just out of luck no matter what.

>
> - Brett
>
> --
> Brett Porter
> brett@apache.org
> http://brettporter.wordpress.com/
> http://au.linkedin.com/in/brettporter
> http://twitter.com/brettporter
>
>
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message