maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anders Hammar <and...@hammar.net>
Subject Re: [VOTE] Maven 3.1.0
Date Tue, 27 Nov 2012 05:27:43 GMT
As we had some issues with an earlier staged Maven version (was it 3.0.4?)
and releasing (something with nginx in front of nexus), it would be great
if we could verify that we don't release something with an similar issue.
So, anyone doing a release the coming days please use the staged 3.1.0!

/Anders


On Tue, Nov 27, 2012 at 1:17 AM, Mark Derricutt <mark@talios.com> wrote:

> The problems I saw only seemed to be affected my projects where I'd
> updated to use 3.0 of the compiler plugin, using the default version used
> by maven 3.1.0 I've not seen the problem.
>
> The problem I was seeing was that Maven was downloading pretty much EVERY
> .pom mentioned in the upstream metadata for my version ranged artifacts and
> not just those from the specified range, this seemed ( from memory ) to
> them be pulling down all of the transitive deps for ALL versions regardless
> of range resolution.
>
> I'll see if I get similar behaviour here at the office on the same project.
>
> On 27/11/2012, at 3:49 AM, Jason van Zyl <jason@tesla.io> wrote:
>
> > What was the issue specifically? Something you think will affect people
> generally?
> >
> > On Nov 26, 2012, at 2:43 AM, Mark Derricutt <mark@talios.com> wrote:
> >
> >> FYI this was with maven-compiler-plugin 3.0 - which Olivier mentioned
> may have some issues?
> >>
> >> On 26/11/2012, at 11:41 PM, Mark Derricutt <mark@talios.com> wrote:
> >>
> >>> Is it me or is 3.1.0 downloading WAY WAY more .pom files from my
> version ranges that earlier versions?
> >>
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message