maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Lamy <ol...@apache.org>
Subject Re: [PROPOSAL] Reporting plugins should require Maven 2.2.1
Date Thu, 12 Jan 2012 06:58:53 GMT
+1

--
Olivier
Le 11 janv. 2012 23:23, "Dennis Lundberg" <dennisl@apache.org> a écrit :

> Hi
>
> I've had a look at this issue in the Checkstyle Plugin
> http://jira.codehaus.org/browse/MCHECKSTYLE-146
>
> The issue is not unique to the Checkstyle Plugin, but rather any plugin
> that uses Doxia 1.1.x or newer. That means at least all reporting
> plugins. I've verified it on the PMD Plugin that I am working on.
>
> All Maven 2 versions come with a bundled Doxia version. This means that
> it is locked and cannot use newer versions of Doxia. Most current
> reporting plugins use Doxia 1.1.x which was introduced in Maven 2.1.0.
> Maven version prior to that cannot use Doxia 1.1 features like Doxia
> Logging.
>
> So when a reporting plugin using Doxia 1.1 is invoked by Maven 2.0.x
> there is a high probability that it will crash, in a way similar to what
> is described in the above issue.
>
> To remedy this I propose that all plugins that use Doxia 1.1+ has its
> Maven prerequisite set to 2.2.1.
>
> Why not 2.1.0 or 2.2.0 you may ask? Well, we don't want people to use
> them because Maven 2.1.0 and 2.2.0 produce incorrect GPG signatures and
> checksums respectively.
>
>
> Comments?
>
>
> This is something that can be done one plugin at a time, when it's due
> for release. We should register JIRA issues for each plugin stating the
> updated Maven prerequisite, to make the change visible to our users.
>
> --
> Dennis Lundberg
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message