maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kristian Rosenvold <kristian.rosenv...@gmail.com>
Subject Re: Intention to release Maven EAR Plugin 2.7
Date Thu, 12 Jan 2012 12:23:43 GMT
I'm doing a quick sweep over plexus-io/archiver aiming for a .1 bump on
both; you might consider
doing a joint release EAR/maven-archiver release to get these included.

I'll be watching general issues/patches on plexus specifically until you
say it's time to press release ;)

(Btw; I have a commit coming up for PLXCOMP-192, thanks to your excellent
analysis)


Kristian



2012/1/9 Stephen Connolly <stephen.alan.connolly@gmail.com>

> On 9 January 2012 17:07, Robert Scholte <apache@sourcegrounds.com> wrote:
> > To use Maven 2.2.1 you need at least jdk5, not the other way around
> (i.e. to
> > use jdk5 you need at least maven 2.2.1).
> > Using Maven 2.0.9 with jdk5 works just as fine.
>
> Let me put this another way, if a plugin is using Java 1.5 code, then
> in my view, it should specify Maven 2.2.1 as a minimum prereq as that
> is the first version of Maven to require Java 1.5...
>
> I don't see any point in genericification of the plugin source code
> unless we are using 2.2.1 as the pre-req.
>
> >
> > And there are still a lot of companies which use Maven 2, because it
> works:
> > there's no need to spend time or money to upgrade to Maven 3.
> >
> > IMHO this should be fixed for Maven 2 as well, but I agree that the patch
> > needs some finetuning.
> >
> > -Robert
> >
> >
> > On Mon, 09 Jan 2012 09:50:08 +0100, Stephen Connolly
> > <stephen.alan.connolly@gmail.com> wrote:
> >
> >> Well IMHO, the patch is perhaps somewhat misguided.
> >>
> >> in m3, there will be resolution from the reactor as priority, so this
> >> patch should only be required in m2... and in order to keep consistent
> >> behaviour, the patch should not be switchable and the reactor search
> >> should have priority. Other than that, the patch might not be a bad
> >> thing...
> >>
> >> on the other hand, since we have moved to java 1.5, I presume we are
> >> switching to maven 2.2.1 at least as a minimum... we could just bump
> >> it to 3.0 and the issue would be "gone"
> >>
> >> -Stephen
> >>
> >> On 8 January 2012 20:52, Robert Scholte <apache@sourcegrounds.com>
> wrote:
> >>>
> >>> Hi,
> >>>
> >>> I've been cleaning up the pom a bit.
> >>> It looks like we can't upgrade the value for mavenFilterVersion due to
> >>> regression, so we have to stay at 1.0-beta-2
> >>> Somehow the escaping character is ignored.
> >>> And the sources now use generics.
> >>>
> >>> The title of MEAR-107 is kind of misleading, it's actually asking for
> >>> reactorProjects support.
> >>> It has a patch, no IT and 3 votes.
> >>> Maybe worth adding?
> >>>
> >>> -Robert
> >>>
> >>> [1] http://jira.codehaus.org/browse/MEAR-107
> >>>
> >>>
> >>> On Sun, 08 Jan 2012 16:51:34 +0100, Jason van Zyl <jason@tesla.io>
> wrote:
> >>>
> >>>>
> >>>> On Jan 8, 2012, at 6:10 AM, Dennis Lundberg wrote:
> >>>>
> >>>>> Hi,
> >>>>>
> >>>>> After working on two rather large issues for the EAR plugin I'm
going
> >>>>> to
> >>>>> release a new version shortly. If there are any more issues that
you
> >>>>> want to work on and want included in this release please let me
know.
> >>>>>
> >>>>> There are currently two unresolved issues scheduled for the 2.7
> >>>>> release.
> >>>>> Unless someone is willing to work on them, I'm going to push them
to
> a
> >>>>> later release.
> >>>>>
> >>>>
> >>>> Sounds reasonable.
> >>>>
> >>>> Thanks for the heads up.
> >>>>
> >>>>>
> >>>>>
> >>>>>
> http://jira.codehaus.org/browse/MEAR#selectedTab=com.atlassian.jira.plugin.system.project%3Aroadmap-panel
> >>>>>
> >>>>> --
> >>>>> Dennis Lundberg
> >>>>>
> >>>>> ---------------------------------------------------------------------
> >>>>> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> >>>>> For additional commands, e-mail: dev-help@maven.apache.org
> >>>>>
> >>>>
> >>>> Thanks,
> >>>>
> >>>> Jason
> >>>>
> >>>> ----------------------------------------------------------
> >>>> Jason van Zyl
> >>>> Founder,  Apache Maven
> >>>> http://twitter.com/jvanzyl
> >>>> ---------------------------------------------------------
> >>>>
> >>>> To do two things at once is to do neither.
> >>>> -—Publilius Syrus, Roman slave, first century B.C.
> >>>>
> >>>>
> >>>>
> >>>
> >>> ---------------------------------------------------------------------
> >>> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> >>> For additional commands, e-mail: dev-help@maven.apache.org
> >>>
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> >> For additional commands, e-mail: dev-help@maven.apache.org
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> > For additional commands, e-mail: dev-help@maven.apache.org
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message